Open Bug 1470200 Opened 3 years ago Updated 4 months ago

Some articles marked as Ready For Localization (RFL) do not trigger dashboard updates across locales

Categories

(support.mozilla.org :: Localization, defect)

defect
Not set
major

Tracking

(Not tracked)

People

(Reporter: mdziewonski, Assigned: mana)

References

Details

Attachments

(2 files)

As reported by Michele and Joergen, Mozillian localizers.

What's going on:
Some articles updated in English (examples below) and marked as RFL (Ready for Localization) are still shown as "Up To Date" instead of "Update Needed" in localization dashboards.

What should be happening:
Each article updated in English and marked as RFL should show up as "Update Needed" on all localization dashboards.

Impact:
This is negatively impacting the localization workflow, making it impossible for localizers to work with content currently awaiting updates across locales.

Articles affected by this:
* https://support.mozilla.org/en-US/kb/what-to-do-if-firefox-wont-play-any-sounds/history
* https://support.mozilla.com/en-US/kb/firefox-options-preferences-and-settings/history

More details:
* https://support.mozilla.org/forums/l10n-forum/713051#post-74115
* https://support.mozilla.com/kb/firefox-options-preferences-and-settings/discuss/7540#post-16616
@Madalina - any chance we could get someone from our supporting developer team to look into the logs for this? Cheers!
Assignee: nobody → mana
Flags: needinfo?(mana)
(In reply to vesper from comment #0)
 
> Articles affected by this:
> *
> https://support.mozilla.org/en-US/kb/what-to-do-if-firefox-wont-play-any-sounds/history
> *
> https://support.mozilla.com/en-US/kb/firefox-options-preferences-and-settings/history
> 
> More details:
> * https://support.mozilla.org/forums/l10n-forum/713051#post-74115
> *
> https://support.mozilla.com/kb/firefox-options-preferences-and-settings/
> discuss/7540#post-16616

The two affected articles listed above are NOT Administration category articles, by the way.  They're "Troubleshooting" and "How to" category articles.  Administration category articles marked RFL are covered separately, in bug 1395242.
See Also: → 1395242
Pinging jpetto and pmac.

Hi folks, this bug is affecting our localization workflow, any chance to have it looked at? 
P.S. If there's a different process we should follow to have major bugs pushed through please let me know.
Flags: needinfo?(pmac)
Flags: needinfo?(mana)
Flags: needinfo?(jon)
I'll take a look today. Thanks for the ping. Leaving NI until I get it sorted.
I believe this was due to me being behind on extracting DB strings. I've now done this and updated strings in the l10n repo in github[0]. Can you please now check again to see if this has fixed the issue? I don't believe I have access to the l10n dashboards to which you refer in comment #0.

Thanks

[0] https://github.com/mozilla-l10n/sumo-l10n
Flags: needinfo?(pmac)
Flags: needinfo?(jon)
Vesper, can you please check and report whether this is fixed? Thanks!
Flags: needinfo?(mdziewonski)
Thank you, Paul!

We'll be monitoring the notification situation for the next few days to see if that fixed it (https://support.mozilla.org/forums/contributors/713073)
https://support.mozilla.org/en-US/kb/install-older-version-of-firefox/history
Readied for localization: Jun 29, 2018, 1:27:35 AM 
as you can see here
https://support.mozilla.org/en-US/kb/install-older-version-of-firefox/revision/162930

Email notification arrived (twice) on July 01, 11:42:58 AM Italian Time (02:42:58 -0700 (PDT))
It did not show up on the dashboard nor when clicking Edit. 
Underpass, my colleague local leader, made the update anyway on July 01, 08:23:37 PM and I have not yet received the email notification of the Italian update.
We have been having email notification issues with SUMO for a few days. I believe :jgmize fixed them here:

https://bugzilla.mozilla.org/show_bug.cgi?id=1472483#c2

Hopefully that at least handles the notification part of this. I'll need to know more about these dashboards if that part is still not working either.
Not sure if this is related, but I noticed a wrong en-US base when updating one article - see https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message/discuss/7582#post-16681 for more.
Here is another one on the Danish Dashboard. https://support.mozilla.org/da/localization/most-visited-translations
The article "Hvordan vælger jeg, hvad der synkroniseres i Firefox?" is Flagged as Up To Date.
Latest Danish revision is from May 14. Latest English revision Flagged as Ready for l10n is from July 6. https://support.mozilla.org/en-US/kb/how-do-i-choose-what-types-information-sync-firefox/history
@Jørgen - Same situation on the Italian dashboard. Latest Italian revision November 3, 2017 (when @Joni updated the en-US article).
How did you realize that there was an update of the en-US version?
(In reply to Michele Rodaro [michro] from comment #13)
> @Jørgen - Same situation on the Italian dashboard. Latest Italian revision
> November 3, 2017 (when @Joni updated the en-US article).
> How did you realize that there was an update of the en-US version?

Hi Michele

I looked at the Danish version of this page :https://support.mozilla.org/it/kb/revisions?locale=en-US&users=&start=&end= and saw that the article "How do I choose what types of information to sync on Firefox?" had a new revision. This does NOT mean the revision has been reviewed/approve and marked as Ready for l10n. I clicked the date 06/lug/2018 04:33:21, which opened this page: https://support.mozilla.org/en-US/kb/how-do-i-choose-what-types-information-sync-firefox/revision/163317. I could see the revision was 'Readied for localization: Jul 6, 2018, 4:43:33 AM'. I found the Danish version of the article and saw it was flagged as UP To Date.
Ok, thanks Jørgen. I never select the en-US locale on that page. 
Furthermore, I did not get the email notification of that article Ready For Localization (see Bug 1204515).
Posted today by Lan in https://support.mozilla.org/en-US/forums/l10n-forum/713051#post-74285

"Again, I see [No differences found] in these articles: Troubleshoot Firefox issues caused by malware [1], I found a fake Firefox update [2], Switch to Firefox Extended Support Release (ESR) for personal use [3]. All of them were approved and RFLed by Alice on 2nd July around 21:00 (my timezone).
"In the fake update article's history, I also see a very strange thing: https://support.mozilla.org/gallery/image/31684 "
<snip>
[1] https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware/history
[2] https://support.mozilla.org/en-US/kb/i-found-fake-firefox-update/history
[3] https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr/history
Flags: needinfo?(mdziewonski)
See Also: → 1204515
Looking at the current status for Firefox articles for my locale (nl) as well as the articles mentioned above and the time frame of their edits and RFL approvals around the time this issue got introduced (first week of July), these 4 articles may be the ones currently causing 4 missing ones to be displayed on our dashboard (315/319):

[1] https://support.mozilla.org/en-US/kb/how-do-i-choose-what-types-information-sync-firefox/history (July 6 edit)
[2] https://support.mozilla.org/en-US/kb/i-found-fake-firefox-update/history (July 1 edit)
[3] https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr/history (July 1 edit)

and additionally
[4] https://support.mozilla.org/en-US/kb/import-bookmarks-internet-explorer-or-microsoft-ed/history (July 8 edit)

Interestingly, the Italian and Russian dashboard currently show only 2 missing ones for the Firefox category for some reason (317/319), yet a "This revision is outdated, but there is a new revision available" warning shows up when attempting to edit [2] and [4] for both locales. That does not happen for nl, and I cannot recall ever seeing it (perhaps related to "own" locales and some other bug? - possibly to be verified by someone else attempting to edit them for nl.) For [4], the en-US history also shows a "Current" status for a previous older revision, which reminds me of some other issue (and bug?).

Alice, can you apply 4 empty RFL edits for these articles, perhaps starting with [2] and [4] only (or [1] and [3] instead) for the reason above just to see what affects/fixes the counters / dashboard updates? (If agreed it’s OK to do so unless a dev would like to investigate prior to doing so, which I don’t expect ;) )
(In reply to Ton [:Tonnes] from comment #17)

> [2] https://support.mozilla.org/en-US/kb/i-found-fake-firefox-update/history
> (July 1 edit)<snip>
> [4] https://support.mozilla.org/en-US/kb/import-bookmarks-internet-explorer-or-microsoft-ed/history
> (July 8 edit)
> <snip>
> Alice, can you apply 4 empty RFL edits for these articles, perhaps starting
> with [2] and [4] only
> <snip>

Empty RFL edits done for [2] and [4] only. Let me know if you want edits for the others.
Thanks Tonnes for your "investigation" and Alice for the Empty RFL edits [2]-[4].

On August 8, I posted this thread on the L10n Forum 
[Attn: Admin] Italian KB Dashboard issue: https://support.mozilla.org/en-US/forums/l10n-forum/713112?last=74662
We get this issue of missing articles and percentages also for Firefox for Android on the Italian dashboard (one article missing).
(In reply to Ton [:Tonnes] from comment #17)
> <snip>
> For [4], the en-US history also shows a
> "Current" status for a previous older revision, which reminds me of some
> other issue (and bug?) 
Bug 769667 (Latest approved revision is not always the current revision
RESOLVED WONTFIX)
See also: bug 1052104  bug 1052594
(In reply to Alice Wyman from comment #18)
> (In reply to Ton [:Tonnes] from comment #17)
> Empty RFL edits done for [2] and [4] only. Let me know if you want edits for
> the others.

Thank you. Apparently the [2] update fixed one counter for nl; it and ru have also updated both of them but the counter has only gone up by 1, so I guess one of the others will do the trick for those.

However and before continuing, could you check for the last edit for [4] (revision 166674) to be really "empty", i.e. whether the last revision has proper content? Probably due to revision 163373 by Lan previously marked as "Current" I’m afraid you clicked "Edit article" rather than use/edit revision 162305 as a base (see diff), so more recent edits were lost.

(In reply to Michele Rodaro [michro] from comment #19)
> We get this issue of missing articles and percentages also for Firefox for
> Android on the Italian dashboard (one article missing).

Not investigated nor sure about Android articles yet, other than one of them being wrongly categorized (see https://support.mozilla.org/en-US/kb/whats-new-firefox-focus-android-version-7/discuss/7665) and hence showing up there for all locales. That’s only 1 of 2 for nl though and not causing our issue (as it is localized for it while I prefer to get things addressed first before doing so), but I’m sure we’ll get there too. ;)
(In reply to Ton [:Tonnes] from comment #21)
> (In reply to Alice Wyman from comment #18)
> > (In reply to Ton [:Tonnes] from comment #17)
> > Empty RFL edits done for [2] and [4] only. Let me know if you want edits for
> > the others.
<snip>
> However and before continuing, could you check for the last edit for [4]
> (revision 166674) to be really "empty", i.e. whether the last revision has
> proper content? Probably due to revision 163373 by Lan previously marked as
> "Current" I’m afraid you clicked "Edit article" rather than use/edit
> revision 162305 as a base (see diff), so more recent edits were lost.

[4] https://support.mozilla.org/en-US/kb/import-bookmarks-internet-explorer-or-microsoft-ed/history
I did indeed make what I thought was an empty edit, meaning I clicked "Edit article". This resulted in an edit to what the db thought was the "current" but which, as you pointed out, caused recent edits to be lost.  I made a new "empty" edit to what was actually the last approved revision and marked it RFL

Bug 769667 should be reopened or a new bug filed.
(In reply to Alice Wyman from comment #22)
> I made a new "empty" edit to what was actually the last approved revision and marked it RFL

Thanks, that fixed the 2nd for nl, so I hope [1] and [3] will be the remaining 2 for nl, and (oddly enough) 1 of them for other locales currently missing 1. The edit didn’t affect Russian this time so probably won’t do so for Italian either. Feel free to apply empty edits to [1] and [3], other locales could update [4] first and check if they want.

> Bug 769667 should be reopened or a new bug filed.

Agree; I’d be in favor of reopening, if only someone can check whether or not it’s related to caching. For sure, this doesn’t "fix itself in a few minutes", so I don’t think it is.
(In reply to Ton [:Tonnes] from comment #23)

> Feel free to apply empty edits to [1] and [3], other
> locales could update [4] first and check if they want.
Done:
[1] https://support.mozilla.org/en-US/kb/how-do-i-choose-what-types-information-sync-firefox/history 
[3] https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr/history
 
> > Bug 769667 should be reopened or a new bug filed.
> 
> Agree; I’d be in favor of reopening, if only someone can check whether or
> not it’s related to caching. For sure, this doesn’t "fix itself in a few
> minutes", so I don’t think it is.
I reopened the bug (see bug 769667 comment 7).
Thanks, Alice :-)
Now everything works fine on the Italian dashboard. I updated the articles after your empty edits (I made an edit without changing anything), and the update fixed the counter. No more missing articles ;-)

@Madalina, any chance for Tasos to look into this problem that seems to exist until now?

Flags: needinfo?(mana)

Can anyone reproduce the issue in production? I was investigating it last night, but could not reproduce the issue locally.

(from comment #28)

This came up again:
https://support.mozilla.org/en-US/forums/l10n-forum/713956

The problem with the https://support.mozilla.org/en-US/kb/get-started-firefox-overview-main-features article (does not show up as "Needs Update" in the localization dashboard, changes not reported in the diff when the article is opened) was resolved by an empty edit marked RFL.

Type: task → defect
Flags: needinfo?(mana)

Hello, this is happening again with the article

https://support.mozilla.org/it/kb/remove-other-bookmarks-folder-from-bookmarks-toolbar

I have received an update warning email, but in the Italian localization dashboard the article is not reported.

Hi Simone,

can you provide a screenshot of both the update warning and the localization dashboard?

Flags: needinfo?(underpass_bugzilla)

Hello, I'm sorry but I've already updated the article and I didn't think about taking a screenshot. I've found that it wasn't shown in the "All products" dashboard but it did appear when I selected "Firefox" from the dropdown menu.

Ok, it's happening again, same article. I'm going to upload the screenshots

Attached image all_products.png

The "update needed" warning doesn't appear when the dropdown menu is showing "All products"

The "update needed" warning does show up when selecting "Firefox" from the products menu.

Flags: needinfo?(underpass_bugzilla)

Got it. So, the glitch only happens on the dashboard when we choose "All products", and not when we choose Firefox specifically.

I do notice that the "All products" table sorts the articles based on Pageview. From this page, https://support.mozilla.org/it/localization/most-visited-translations, the correspondent article has 196 page views. I expected, that might be the reason why it wasn't showed up there. Because the list only shows the top 20 articles based on the page view, maybe that article doesn't have enough page views to be listed on the top 20. I could be wrong, though. Because I couldn't see the full list when you took the screenshot.

You need to log in before you can comment on or make changes to this bug.