Closed Bug 1470625 Opened 2 years ago Closed 1 year ago

Remove repo scopes from active_scm_level_* roles

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dustin, Unassigned)

References

(Regression)

Details

Attachments

(2 files)

No description provided.
No longer blocks: 1415868
Depends on: 1415868
Depends on: 1465842
Depends on: 1487500
tomprince suggested this arrangement:

 level-1 users
    scopes to perform actions on level-1 repos

 level-2 users
    scopes to perform actions on level-2 repos

 level-3 users
    scopes to perform actions on level-3 repos
    scopes to execute actions on level-1 repos

That last line means that level-3 users would get e.g., `assume:repo:hg.mozilla.org/try:*` and basically have lots of level-1-related scopes, but not level-3-related scopes.  And level-1 users wouldn't have much of anything except retrigger, cancel, etc.

I think that change will remove a lot of the potential "sharp edges" that would prevent our most efficient engineers from doing things they've done for a long time, like editing try tasks in the task creator to tweak them.
Depends on: 1485680
Assignee: dustin → nobody

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:tomprince, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mozilla)
Flags: needinfo?(mozilla)

I've removed scopes for level-2/3 repos from active_scm_level_2/3, however I haven't touched the active_scm_level_1 role. I think this is enough for the moment. I suspect there are enough people that have L1 but not L3 by choice, rather than because of trust, and being able to directly create L1 tasks is probably useful for them.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Regressed by: 1564309
You need to log in before you can comment on or make changes to this bug.