Closed Bug 1471522 Opened 2 years ago Closed 7 months ago

Inline blocklist clients initialization into Blocklist.jsm

Categories

(Toolkit :: Blocklist Implementation, enhancement, P3)

61 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: leplatrem, Assigned: leplatrem)

References

Details

Attachments

(1 file)

The implementation of blocklist clients was started in ``services/common/``.
This code was remodeled and generalized as RemoteSettings, which lead to two pieces: the generic part in ``services/settings/`` and its instantiation for blocklists remained in ``services/common/``.

We would like to move the instantiation of Addons/Plugins/Gfx blocklist clients to ``./toolkit/mozapps/extensions/Blocklist.jsm``. 

This will mainly require some refactoring in the tests. For example, the signature verification test suite of Remote Settings is implemented using the certificates blocklist client. 

We also need to find a place for Certificates and Pinning which are not going to be used in ``Blocklist.jsm`` when implementing Bug 1257565.
Mark do you have any suggestion?
Flags: needinfo?(mgoodwin)
(In reply to Mathieu Leplatre from comment #0)
> The implementation of blocklist clients was started in ``services/common/``.
> This code was remodeled and generalized as RemoteSettings, which lead to two
> pieces: the generic part in ``services/settings/`` and its instantiation for
> blocklists remained in ``services/common/``.
> 
> We would like to move the instantiation of Addons/Plugins/Gfx blocklist
> clients to ``./toolkit/mozapps/extensions/Blocklist.jsm``. 
> 
> This will mainly require some refactoring in the tests. For example, the
> signature verification test suite of Remote Settings is implemented using
> the certificates blocklist client.

That's fine; let me know if I can help at all.
 
> We also need to find a place for Certificates and Pinning which are not
> going to be used in ``Blocklist.jsm`` when implementing Bug 1257565.
> Mark do you have any suggestion?

I'm not completely sure about what you mean - do you mean a new location for those blocklist clients, or a new place to invoke the sync?
Flags: needinfo?(mgoodwin) → needinfo?(mathieu)
> That's fine; let me know if I can help at all.

Thanks! 

Yes I believe I would need your help to generate the signatures for some new generic/fake data instead of the current certificates records, using https://searchfox.org/mozilla-central/source/services/common/tests/unit/test_blocklist_signatures

> I'm not completely sure about what you mean - do you mean a new location for those blocklist clients, or a new place to invoke the sync?

I mean a new place for the instanciation of those blocklist clients. The sync is now invoked with its own dedicated timer (Bug 1458917)
Flags: needinfo?(mathieu)
Component: Blocklist Policy Requests → Blocklist Implementation
Priority: -- → P3
Duplicate of this bug: 1447332
Blocks: 1543597
See Also: → 1543598
Assignee: nobody → mathieu
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bf04bcac450c
Move blocklist target app filter to Blocklist module r=Gijs
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.