title descriptions (tooltips) block right click context menu

REOPENED
Unassigned

Status

()

Core
XUL
--
minor
REOPENED
16 years ago
4 years ago

People

(Reporter: jg, Unassigned)

Tracking

Trunk
Future
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    200202051013

Right click on the links in the body, then the menu items are obsured by the
title tooltip

Reproducible: Always
Steps to Reproduce:
1.Right click on the links in the body, then the menu items are obsured by the
title tooltip
2.
3.

Actual Results:  Blocks the 2nd item on the menu, or others

Expected Results:  should display behind or not at all while the context menu is
open


<a href="/internet/ad.htm" target="_blank" title="Click here for more
information on how to advertise in IEEE Internet Computing.">IEEE
                    Internet Computing</a>
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: title descriptions block right click context menu → title descriptions (tooltips) block right click context menu

Comment 1

16 years ago
-> toolkit
Assignee: sgehani → jaggernaut
Component: XP Apps → XP Toolkit/Widgets
QA Contact: paw → jrgm

Comment 2

16 years ago
this works for me on linux or win2k (linux with enlightenment/gnome with either 
focus-follows-mouse or click-to-focus).
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
reopen. I see this bug in linux trunk cvs (sawfish 1.0.1, XFree86 4.1.0.1).

Steps to reproduce:
1. Enter this link with the mouse: bug 147288
2. Right click -> context menu appears
3. Move mouse within the link, wait a second -> tooltip appears on top of
   context menu.

Bonus level:
4. Move onto context menu without straying onto the page outside the link on
   the way there -> tooltip remains on context menu
5. Click on tooltip -> bug 113536 (chrome ignores all mouse clicks)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

16 years ago
Target Milestone: --- → Future

Comment 4

16 years ago
I see this bug also (using recent Mozilla trunk builds on GNU/Linux with
Gnome+sawfish).  It's a terrible pain on sites which over-use tooltip bubbles.

I confirm Tuukka's observations, including the "bonus level" part: I think the
latter justifies requalifying this bug's importance as more than "minor";
without it ("it" being the "bonus level" in question), the problem would indeed
be a mere inconvenience, but there we can wreak havoc in the whole chrome (try,
for example, activating the bonus level and then using keyboard shortcuts into
the context menu, e.g., "open link in new tab" - then the whole interface starts
behaving strangely).

Here is a link to a nice playground to experiment with this bug: <URL:
http://www.eleves.ens.fr:8080/home/madore/.test/bubbles.html >.

Comment 5

16 years ago
Still seeing this in 2002080708.  I actually encountered it using Bugzilla,
which doesn't use popups in a particularly bizarre way.

Comment 6

16 years ago
Actually, is this a dup of bug 155018?
Not really.
clicking on a tooltip messes kills the rat -> bug 113536, bug 156764
tooltip appears on top of context menu -> this bug
both of the above, approximately -> bug 155018
...I suppose maybe this'll be fixed in 155018 though, marking dep
Depends on: 155018

Comment 8

16 years ago
*** Bug 162065 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Depends on: 164639

Updated

16 years ago
No longer depends on: 164639

Updated

16 years ago
Depends on: 20016

Comment 9

15 years ago
I have the same problem with Mozilla 1.2.1 on Mac OS 9.1: the tooltip hides the
second item of contextual menus "open link in new tab", as I use very often this
menu when browsing a blog for example it is very annoying. Try on
http://www.nitot.com/standards/blog/

Comment 10

15 years ago
The tooltip seems to go away in an appropriate way in FireBird 2003090 for Linux.

Comment 11

14 years ago
Do you think that a tab tooltip blocking middle clicks in Firefox would be
covered by this bug?

Comment 12

14 years ago
Perhaps this should be a dup of bug 45522 - tooltips should disappear on
input/motion

Updated

10 years ago
Assignee: jag → nobody
You need to log in before you can comment on or make changes to this bug.