while a menu is open, :hover (and tooltips) should only apply to the menu

VERIFIED DUPLICATE of bug 20016

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 20016
16 years ago
10 years ago

People

(Reporter: timeless, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a+) Gecko/20020707
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US

tested in ie5w98se and various windows applications.

basically when you're interacting with a menu/tree of menus you're only supposed
to be interacting with them.  it should be as if there was a special window
containing just the menus and no hover effects should apply to the application
window behind the menu window.

Reproducible: Always

Steps to Reproduce:
1. hover over "bug 146242"
2. mouse a bit to the right
3. right click
4. hover over that text in step 1.

Actual Results:  
after steps 1 and 4 you see a tooltip

Expected Results:  
no tooltip after step 4

this affects content links, truncated text (list views and trees), toolbar buttons

explorer.exe (shell): list view, folder tree
iexplore.exe (browser): links, toolbar buttons
depends.exe (walker): dependency tree hierarchy
filemon.exe (monitor): collumns view

see also bug 164608 which is another menu consistency issue, and like mpt said
there, if this is fixed in a recent build, i'll eat my hat. (I've actually used
much more recent nightlies where it isn't fixed, but the computer with them is
currently refusing to talk to me)

fixing this would fix bug 146242, bug 147670, and bug 147288
(Reporter)

Comment 1

16 years ago
err, that application list is a list of applications where the problem does not
occur in the area listed when you activate a menu.
Blocks: 146242, 147288, 147670

Comment 2

16 years ago
Confirming this behaviour.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020824

-Brett

Comment 3

16 years ago
This is a dupe.

*** This bug has been marked as a duplicate of 20016 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
vrfy dupe
No longer blocks: 146242, 147288, 147670
Status: RESOLVED → VERIFIED
(Reporter)

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.