"Saved to Library!" popup does not obey toolkit.cosmeticAnimations.enabled=false

VERIFIED DUPLICATE of bug 1470776

Status

()

VERIFIED DUPLICATE of bug 1470776
9 months ago
9 months ago

People

(Reporter: from_bugzilla2, Unassigned)

Tracking

62 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20180621064021

Steps to reproduce:

1. Set toolkit.cosmeticAnimations.enabled=false
2. Bookmark a new page


Actual results:

The checkmark icon in the "Saved to Library!" popup is still animated


Expected results:

The checkmark icon in the "Saved to Library!" popup should not animate

(or, even better for me personally, the popup should not appear at all, since I can't seem to catch it with the Browser Inspector's "Pick an element from the page" feature so I can figure out what I need to "display: none !important" in my userChrome.css)
(Reporter)

Comment 1

9 months ago
Oh, a quick correction. I posted this bug from my Firefox 52 ESR profile out of habit, because it just happened to be the one that is currently on my centre monitor and logged into Bugzilla.

The browser where I'm experiencing the problem (on my right-hand monitor) is:

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180705151535

Comment 2

9 months ago
(In reply to Stephan Sokolow from comment #0)
> I can't seem to catch it with the Browser Inspector's "Pick an element
> from the page" feature so I can figure out what I need to "display: none
> !important" in my userChrome.css)

/* Hide "Saved to Library!" bookmark confirmation popup */
#confirmation-hint { display: none !important; }

( The feature was implemented in bug 1459907. I had a look at the patch there — the CSS specifically:
https://reviewboard.mozilla.org/r/252056/diff/6/#10 )
Status: UNCONFIRMED → RESOLVED
Has STR: --- → yes
Last Resolved: 9 months ago
Component: Untriaged → Bookmarks & History
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Version: 52 Branch → 62 Branch
Duplicate of bug: 1470776
(Reporter)

Comment 3

9 months ago
Thanks and sorry for the dupe. I should have tried more synonyms before opening this.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.