Implement new bookmark confirmation

VERIFIED FIXED in Firefox 62

Status

()

enhancement
P3
normal
VERIFIED FIXED
a year ago
4 months ago

People

(Reporter: dao, Assigned: dao)

Tracking

(Depends on 1 bug, Blocks 2 bugs)

Trunk
Firefox 62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62 verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

a year ago
When saving a bookmark, flip the dialog like a card that says "Saved to your Library".

Amy, can you provide the spec for the animation?
Flags: needinfo?(amlee)
Flags: needinfo?(amlee)
(Assignee)

Comment 1

a year ago
Amy, are you going to work on this spec? Already working on it? Are you the wrong person to ask? Please respond to the needinfo rather than just cancelling it.
Flags: needinfo?(amlee)
Priority: -- → P3
(Assignee)

Updated

a year ago
Keywords: uiwanted
Hi Dao, 

Really sorry I didn't realize I cancelled the NI, not sure how that happened. Aaron and I are meeting tomorrow to finalize the spec for you. I'll attach when ready.
Flags: needinfo?(amlee)
(Assignee)

Updated

11 months ago
Summary: Implement save bookmark flip animation → Implement new bookmark confirmation animation
(Assignee)

Updated

11 months ago
Blocks: 1464700
(Assignee)

Updated

11 months ago
Keywords: uiwanted
(Assignee)

Updated

10 months ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
(Assignee)

Updated

10 months ago
Summary: Implement new bookmark confirmation animation → Implement new bookmark confirmation
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 10

10 months ago
Comment on attachment 8986753 [details]
Bug 1459907 - Implement new bookmark confirmation.

Turns out Aaron isn't currently available.
Attachment #8986753 - Flags: ui-review?(abenson)

Comment 11

10 months ago
mozreview-review
Comment on attachment 8986753 [details]
Bug 1459907 - Implement new bookmark confirmation.

https://reviewboard.mozilla.org/r/252056/#review258848

::: browser/base/content/browser.js:8522
(Diff revision 5)
>    },
>  };
> +
> +var ConfirmationPanel = {
> +  /**
> +   * Shows the confirmation panel.

I would be nice to explain what is the "confirmation panel", maybe with a couple examples too, we have so many notifications and panels around...
Attachment #8986753 - Flags: review?(mak77) → review+
(Assignee)

Comment 12

10 months ago
I can add an explanation. Related too that, do you have ideas for a better name than "confirmation panel"? I'm not too happy with that myself.
Flags: needinfo?(mak77)
Comment hidden (mozreview-request)
(Assignee)

Updated

10 months ago
Flags: needinfo?(mak77)

Comment 14

10 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b8939927a9b9
Implement new bookmark confirmation. r=mak

Updated

10 months ago
Duplicate of this bug: 1458274

Comment 16

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b8939927a9b9
Status: ASSIGNED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
(Assignee)

Updated

10 months ago
No longer blocks: 1464700

Comment 17

10 months ago
Please respect toolkit.cosmeticAnimations.enabled;false

Comment 18

10 months ago
Verified the new bookmark confirmation based on this video https://cl.ly/043u3C0p3W25 considering the "Saved to library" text in the latest Nightly 63.0a1 (2018-06-26)) version. On Windows 10 x64 and Mac OS X 10.1. it looks good. 
However, on Ubuntu 16.04. there is shadow that does not seem to be intended. Please check the attached screenshot.
 
Can you please confirm if the message on Ubuntu is incorrectly displayed?
Flags: needinfo?(dao+bmo)

Comment 19

10 months ago
(Assignee)

Comment 20

10 months ago
(In reply to Timea Babos from comment #18)
> However, on Ubuntu 16.04. there is shadow that does not seem to be intended. Please check the attached screenshot.
> 
> Can you please confirm if the message on Ubuntu is incorrectly displayed?

Indeed.
Flags: needinfo?(dao+bmo)

Comment 21

10 months ago
I reported Bug 1471558 for the above mentioned issue regarding the message on Ubuntu.

I also checked on Firefox Beta 62.0b3 and the results are the same as mentioned in Comment 18.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1484275
(Assignee)

Updated

4 months ago
Blocks: 1513228
(Assignee)

Updated

4 months ago
Depends on: 1515093
You need to log in before you can comment on or make changes to this bug.