[WebComponents] Middle click not working on <a href> in shadowDOM

RESOLVED DUPLICATE of bug 1480130

Status

()

RESOLVED DUPLICATE of bug 1480130
8 months ago
12 days ago

People

(Reporter: xaviermd, Unassigned)

Tracking

({nightly-community})

63 Branch
nightly-community
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180716100102

Steps to reproduce:

- Go on https://dascritch.net/vrac/.projets/audiowc/index.html (NOTE : <import> polyfilled) or download https://github.com/dascritch/cpu-audio/releases/tag/5.pre1
- Middle-click on the title of the audio player (b.e. « Au carnaval avec Samba Résille (2003) »)



Actual results:

A new tab should have been opened with the linked URL


Expected results:

Nothing
Keywords: nightly-community
(Reporter)

Updated

8 months ago
Summary: [WebComponents] Middle click not working on <a> in shadowDOM → [WebComponents] Middle click not working on <a href> in shadowDOM
(Reporter)

Comment 1

8 months ago
Sorry, i wrote it wrong : 

« A new tab should have been opened with the linked URL » is the EXPECTED result, of course.

Comment 2

8 months ago
I could reproduce this issue on 

Version 	63.0a1
Build ID 	20180720101508
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Status: UNCONFIRMED → NEW
Component: Untriaged → Event Handling
Ever confirmed: true
Product: Firefox → Core
Have you tried the very latest Nightly, or perhaps it should be tomorrow's Nightly.
As far as I see, this works now, at least using mozilla-inbound build.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1480130
(Reporter)

Comment 5

8 months ago
YES ! Greaaaat ! I works now !
Component: Event Handling → User events and focus handling
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.