Closed Bug 1476596 Opened 3 years ago Closed 3 years ago

Mozilla Location Services enables itself

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
critical

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63blocking verified)

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 blocking verified

People

(Reporter: pwd.mozilla, Assigned: vlad.baicu)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180712193408

Steps to reproduce:

Despite being disabled, it's being envoked somehow and launching a black screen. It's also preventing Fennec from being updated from via the notification.
Severity: normal → critical
OS: Unspecified → Android
Hardware: Unspecified → All
Marked as critical due to the fact that the feature is toggling itself on despite being off and that's essentially stealing user data.
Clearly not something done on purpose.
Summary: Mozilla Location Servies has gone haywire → Mozilla Location Services enables itself
Vlad, could you please have a look asap? Thanks
Blocks: 1474961
Flags: needinfo?(vlad.baicu)
Assignee: nobody → vlad.baicu
Flags: needinfo?(vlad.baicu)
I have been told that it is Android Oreo only.
I have reached out to the QA team, investigated it and concluded that the issue reproduces on Oreo+ devices after reboot.

Upon investigating, the bug appears to be only visual with just the notification being shown and the stumbler does not collect any data because after reboot it does not reach onHandleIntent in StumblerService.
Attachment #8993008 - Flags: review?(sdaswani) → review?(nchen)
Comment on attachment 8993008 [details]
Bug 1476596 - Prevent Stumbler notification being shown after reboot.

https://reviewboard.mozilla.org/r/257824/#review264776
Attachment #8993008 - Flags: review?(nchen) → review+
I see that there's been a mention of the notification and not collecting information, which is a relief, but what about the sporadic pop-up that happens intermittently and generally after the screen has been off for a while?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
I had to uninstall Nightly on my Pixel 2 because this bug essentially makes the phone unusable. It causes problems even when I'm not actively using the app.
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/01417121e398
Prevent Stumbler notification being shown after reboot. r=jchen
NI-ing Oana from QA in order to test the other signaled cases to make sure we haven't missed something
Flags: qe-verify+
Flags: needinfo?(oana.horvath)
(In reply to William Lachance (:wlach) (use needinfo!) from comment #9)
> I had to uninstall Nightly on my Pixel 2 because this bug essentially makes
> the phone unusable. It causes problems even when I'm not actively using the
> app.

Almost the same behavior on my Pixel 2 - logged for the blank screen Bug 1476606
Blocks: 1476606
https://hg.mozilla.org/mozilla-central/rev/01417121e398
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
From what I saw, the Mozilla location service notification only appears after a reboot. If there are any other leads in the code that might suggest a different way to reproduce it, please let me know.

The blank screen pop-up is a different issue (it looks like it's the Nightly crash reporter, which can be seen better on a Samsung S8: https://www.screencast.com/t/vHHs2Hiwe) which is already logged here by Ioana: Bug 1476606 - caught it by leaving the app open with the screen on. Also saw it by updating nightly 07/17 to 07/18, with these crashes: Bug 1476754, Bug 1476681.
Flags: needinfo?(oana.horvath)
Blocks: android-o
This didn't appear anymore the whole day after the fix, did a couple of device reboots and still hasn't shown up. I think it can be marked as fixed. 

Devices verified on:
Google Pixel (Android 9)
Samsung Galaxy S8 (Android 8.0)
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.