Closed Bug 1477783 Opened Last year Closed Last year

Async blob causes us to always reupload blob textures (http://snapsvg.io/demos/#game got much slower with async blob)

Categories

(Core :: Graphics: WebRender, defect)

63 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

(Blocks 5 open bugs)

Details

(Keywords: regression)

It went from 60fps to 20fps and we're spending all of our time uploading textures:
https://perfht.ml/2LzJJl6
Flags: needinfo?(nical.bugzilla)
It looks like we're reuploading even when the contents of the blobs haven't changed.
Summary: http://snapsvg.io/demos/#game got much slower with async blob → Async blob causes us to always reupload blob textures (http://snapsvg.io/demos/#game got much slower with async blob)
Assignee: nobody → jmuizelaar
Fixed via bug 1477505.
Status: NEW → RESOLVED
Closed: Last year
Flags: needinfo?(nical.bugzilla)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.