Closed Bug 1478477 Opened Last year Closed Last year

Developer Edition Mac installer has no background image

Categories

(Firefox :: Theme, defect, P5)

62 Branch
Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox63 --- verified

People

(Reporter: strugee, Assigned: timdream)

References

Details

(Keywords: regressionwindow-wanted)

Attachments

(2 files)

Attached image screenshot
Opening a fresh Developer Edition installer from https://www.mozilla.org/en-US/firefox/developer/ results in a window with a plain white background (i.e. the default for .dmg images). AFAIK this is supposed to have some sort of graphic; certainly the Nightly installer has one.

I'm attaching a screenshot of the behavior. Launching the Developer Edition application and going to the About window indicates 62.0b11, Aurora update channel. about:support indicates 20180723144101 as the build id; about:buildconfig indicates https://hg.mozilla.org/releases/mozilla-beta/rev/88222b8b526d8a6a0f2e4ca099f425af17f7d10d as the hg revision.

Filing into Untriaged because I thought this should go into the Installer component, but I wasn't sure since I think that might be just for the Windows wizard application and not for the "static" Mac installer .dmg file.
I can confirm the reproduction of this issue. The installer's pop-up is incorrectly displayed in the case of the Firefox Developer Edition, but not in the case of Firefox Nightly, Firefox Beta or Firefox Release builds.

The actual difference is that the Developer Edition installer pop-up has a white background instead of black and the browser's and Application Folder's position are not aligned properly.

I can confirm the reproduction on Mac OS X 10.12.6 and 10.13.6.

I am also unsure about the correct component, but I believe that the correct one has to be "Installer". If incorrect,I ask the developers tolerate my low technical knowledge level and set it accordingly.

Thank you!
Component: Untriaged → Installer
Version: 60 Branch → 62 Branch
Bugs involving the DMG background image always seem to end up in Theme, so I'll move this one there too.

Dolske (since it looks like Tim is out), do you think this could be related to bug 1454610?
Component: Installer → Theme
Flags: needinfo?(dolske)
Priority: -- → P5
Hmm, we did touch this stuff for Quantum in bug 1399731  (where it had been broken for a long time!) / bug 1403202, pretty sure it was working after those fixes, so something since regressed.

Tim: anything jump out at you for the background.png than changed?
Flags: needinfo?(dolske) → needinfo?(timdream)
Duplicate of this bug: 1455768
From bug 1455768 comment 1:

[...] appears to be caused by the volume name of the DMG ("Firefox Developer Edition") being different from the expected mount point in /browser/branding/aurora/dsstore ("/Volumes/FirefoxDeveloperEdition", note the lack of spaces). I'm not sure how to regenerate that file, so I can't even be 100% certain that's the problem.

Hmm, we did rename some stuff late last year to add spaces -- see bug 1407285 and friends. So that sounds suspicious.

See bug 1435359 comment 2 for steps on how to regenerate dsstore.
I am going to regenerate dsstore here to see if it fixes anything.
Assignee: nobody → timdream
Status: NEW → ASSIGNED
Flags: needinfo?(timdream)
Following steps in bug 1435359 comment 2 I have managed to restore the icon
position and the background image of the Developer Edition DMG.

We should uplift this to all affect versions.
Bug 1435359 comment 2 might be further simplified by converting the generated DMG to read-write, modify it in Finder, and converting it back again. I didn't do that here though, but the next person might want to take that shortcut.
Attachment #9001800 - Flags: review?(dolske)
Comment on attachment 9001800 [details]
Bug 1478477 - Update .DS_Store for Firefox Developer Edition r=dolske

Justin Dolske [:Dolske] has approved the revision.
Attachment #9001800 - Flags: review+
Pushed by tchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f322012f5f78
Update .DS_Store for Firefox Developer Edition r=Dolske
Attachment #9001800 - Flags: review?(dolske)
https://hg.mozilla.org/mozilla-central/rev/f322012f5f78
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
I can't properly validate this fix because it wasn't occurring on the Nightly version, to begin with. I can confirm that it the issue is STILL not occurring in the latest Nightly (v63.0a1 - 2018-08-23).

I will set the firefox63 flag as verified since no new issues are seen after the push and I will wait for an uplift to Aurora channel to properly verify the fix.

Thank you!
I can confirm that Firefox 63b2.dmg from https://www.mozilla.org/en-US/firefox/developer/ has proper background.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.