Closed Bug 1478578 Opened 2 years ago Closed 2 years ago

Previous value of task-tree filtergroup aren't restored from xulstore.json at load time

Categories

(Calendar :: Tasks, defect)

Lightning 6.5
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: MakeMyDay, Assigned: darktrojan)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

In the task view, the lefthand-side widget to determine the applied view filter doesn't restore the previous value at application load time form xulstore.json - it sticks with |throughcurrent| aka |Current tasks|.

Changes at runtime are persisted poperly when leaving the task view and restored accordingly after switching back to the task view tab.

Works in ESR 60b10, but fails in Lightnign 6.5. Since this is an load time only issue, it's probably a race condition related to the wx changes (n.b.: the patch for bug 1477958 doesn't resolve the issue).
What about the patch for bug 1477956?
Applying this alone or this and that from bug 1477958 doesn't change anything. Setting is still not restored.
Blocks: 1478608
Gah! The mere act of adding a radiogroup to the DOM resets its value. This is going to be an ugly fix.
Blocks: 1476259
Depends on: 1477956
Looks like we're back to restoring (some) attributes before the overlaid elements are added to the document.
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #8995453 - Flags: review?(philipp)
Comment on attachment 8995453 [details] [diff] [review]
1478578-radiogroup-persist-1.diff

Review of attachment 8995453 [details] [diff] [review]:
-----------------------------------------------------------------

Looking at all the work we've been putting into the overlay loader, I kind of wish we could immediately stop doing so and still get extension authors ready for WX. </rant>
Attachment #8995453 - Flags: review?(philipp) → review+
Keywords: checkin-needed
Patch doesn't apply.
Keywords: checkin-needed
Oh yeah, still needs bug 1477956.
Same change, different place. There's no need for this to wait for the other patch.
Attachment #8995453 - Attachment is obsolete: true
Attachment #8996659 - Flags: review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/8ba6a042837c
Restore persisted value of radiogroup early to prevent it being overwritten. r=philipp
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 6.5
You need to log in before you can comment on or make changes to this bug.