Closed Bug 1479478 Opened Last year Closed Last year

Exclude default search URLs from topsites

Categories

(Firefox :: New Tab Page, enhancement, P1)

52 Branch
enhancement

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.3 - Aug 6
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: mkaply, Assigned: k88hudson)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Basic proposal is that it doesn't make sense to put default search URLs in top sites.

We should exclude URLs that match the default search engine.

We can use ParseSubmissionURL to determine this.
Assignee: nobody → khudson
Severity: normal → enhancement
Iteration: --- → 63.3 - Aug 6
Priority: -- → P1
Blocks: 1479806
Keywords: meta
Keywords: meta
Whiteboard: [has-pr]
Whiteboard: [has-pr]
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/e7779578da1e1d88c019709fc87f1dbb6eb3cd9c
Bug 1479478 - Support alexa top 5 search for top sites filtering
Also turns on the search filter experiment be default

https://github.com/mozilla/activity-stream/commit/6a130ecb234bb46f449cbaf33522aed55dbcc621
Merge pull request #4287 from k88hudson/bug1479478b

Bug 1479478 - Support alexa top 5 search for top sites filtering
Blocks: 1481559
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
I have verified that the default search engines are excluded from the "Top Sites" area using the following steps:

1. I've installed an older version of "Firefox Nightly" (from 07/30/2018).
2. Populated the "Top Sites" area with different search engines (eg. "Google", "Yahoo" "Duckduckgo").
3. Updated the browser to the latest version.

After the update the search engines, that were displayed in the "Top Sites" area, were excluded and replaced by the new default ones such as "Google" and Amazon.
Status: RESOLVED → VERIFIED
Blocks: 1482579
Blocks: 1482398
I have verified that the issue is not reproducible in the latest Beta (62.0b18 Build ID 20180816151750) on Windows 10, Mac 10.13 and Arch Linux x64. The targeted pre-existing Top Sites are correctly converted to search shortcuts (Google) or no longer displayed (Duckduckgo, Bing).
See Also: → 1499389
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.