Closed Bug 1499389 Opened 3 years ago Closed 3 years ago

Top site is removed after it is added as a default search engine

Categories

(Firefox :: New Tab Page, defect)

defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox63 --- fix-optional
firefox64 --- affected

People

(Reporter: cbaica, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]:
- Firefox 64.0a1
- Firefox 64.0b1
- Firefox 63.0b14

[Affected platforms]:
- Win 10 x64
- Win 7 x32
- mac OS 10.13
- Ubuntu 16.04

[Steps to reproduce]:
1. Launch Firefox.
2. Go to about:preferences#search and add a search bar.
3. Open a new tab and input some text in the search bar.
4. Right click on the twitter icon at the bottom of the search list and set it as a default search engine. 

[Expected result]:
- Twitter is set as a default engine and still displayed as a top site.

[Actual result]:
- Twitter is set as a default engine, but no longer displayed as a top site.

[Regression range]:
- This is a recent regression. I have managed to track the issue to this changeset: 
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=056a3c3fcc42cf5e22bfa979b0390b3d88d83b65&tochange=f650c0df72f9f1dc616bb1510a36f894400e8b84
- From that long list, it looks like the issue was introduced by ticket 1481559.

[Additional notes]:
- The same issue occurs if the default engine is set from about:preferences#search and then a new tab is opened.
- Currently the issue occurs only for amazon and twitter, but it does not occur for Wikipedia.
- It could be that the implementation of 1479478 causes the top-site removal.
This probably is what bug 1479478 is intentionally doing. k88hudson, is this the expected behavior?
Flags: needinfo?(khudson)
See Also: → 1479478
Talking with other QA involved on this, I got the impression that bug 1479478 removes the searches made with the engine from the top sites section, not the search engine itself.
mkaply could you please also have a look at this?
Flags: needinfo?(mozilla)
Has Regression Range: --- → yes
Keywords: regression
Unfortunately I will be unavailable for a couple weeks so I can't look at this. Moving to mikedeboer to have someone on the search team offer their opinion.
Flags: needinfo?(mozilla) → needinfo?(mdeboer)
I'd like Kate and/ Ed to finish their investigation here first, before I can tell whether we need to dig through the code.
In the coming two weeks, please feel free to needinfo :daleharvey.
Flags: needinfo?(mdeboer)
It's more of a question of what the product intent was. I'm pretty sure it was to remove any urls from the search domain instead of what the reporter is suggesting of only removing search result pages.
Can we get a priority on this as well, please?
Flags: needinfo?(tspurway)
This is intentional and was done as part of the 'Search Filtering' of Top Sites in bug #1479478
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(tspurway)
Resolution: --- → INVALID
Flags: needinfo?(khudson)
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.