Closed Bug 1480852 Opened Last year Closed Last year

Crash in android.os.TransactionTooLargeException: data parcel size 1053364 bytes at android.os.BinderProxy.transactNative(Native Method)

Categories

(Firefox for Android :: General, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 + fixed
firefox64 --- fixed

People

(Reporter: marcia, Assigned: andrei.a.lazar)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, topcrash, Whiteboard: --do_not_change--[priority:high])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-5bf252c5-6379-4ba9-8c69-5c2070180801.
=============================================================

Per comments in Bug 1476424#c14, we still are having crashes in this signature. I will add the signatures that I am seeing that are still happening after the fix for the other bug.

Note that we also were asked to try to get STR for this bug. 

Top 10 frames of crashing thread:

0 libxul.so libxul.so@0x13d8098 
1 libxul.so libxul.so@0x13d7451 
2 base.art (deleted) base.art @0x5d272 
3 base.odex base.odex@0x838c3 
4 base.art (deleted) base.art @0x5d272 
5 base.art (deleted) base.art @0x9c96 
6 libart.so libart.so@0x414575 
7 base.vdex base.vdex@0x650fff 
8 libart.so libart.so@0x4197ed 
9 base.art (deleted) base.art @0x5035a 

=============================================================
Crash Signature: Method) ] → Method) ] [@ android.os.TransactionTooLargeException: data parcel size 1185768 bytes at android.os.BinderProxy.transactNative(Native Method)] [@ android.os.TransactionTooLargeException: data parcel size 595316 bytes at android.os.BinderProxy.transactNa…
Crash Signature: android.os.TransactionTooLargeException: data parcel size 938424 bytes at android.os.BinderProxy.transactNative(Native Method)] [@ ndroid.os.TransactionTooLargeException: data parcel size 676456 bytes at android.os.BinderProxy.transactNative(Native → android.os.TransactionTooLargeException: data parcel size 938424 bytes at android.os.BinderProxy.transactNative(Native Method)] [@ android.os.TransactionTooLargeException: data parcel size 676456 bytes at android.os.BinderProxy.transactNative(Native
[Tracking Requested - why for this release]: Nominating for tracking since this has risen to the top crash based on the accumulation of signatures.

Here is a short query that shows all of the recent crashes in this signature in 63 in the last 7 days: https://bit.ly/2KvYote. I count about 52 crashes, which makes this the current top crash on nightly.
Keywords: topcrash
ni on Andrei to see what else we can do here regarding this crash. Note I did not all all the signatures in Comment 1 to the bug - there are quite a few all with different data parcel sizes.
Flags: needinfo?(andrei.a.lazar)
Assignee: nobody → andrei.a.lazar
Flags: needinfo?(andrei.a.lazar)
Adding another signature which has about 4 crashes.
Crash Signature: Method)] → Method)] [@ android.os.TransactionTooLargeException: data parcel size 3124112 bytes at android.os.BinderProxy.transactNative(Native Method)]
Crash Signature: Method)] [@ android.os.TransactionTooLargeException: data parcel size 3124112 bytes at android.os.BinderProxy.transactNative(Native Method)] → Method)] [@ android.os.TransactionTooLargeException: data parcel size 3124112 bytes at android.os.BinderProxy.transactNative(Native Method)] [@ android.os.TransactionTooLargeException: data parcel size 3121720 bytes at android.os.BinderProxy.transactNa…
Hello Cristian: Do you think work on this will happen before the 63 cycle concludes? We are getting closer to the end of the cycle and I believe we have about 52 crashes in this signature in the last 7 days - that number will increase I believe when we move to beta. I just finished nightly crash triage and noticed 20180813100105 nightly build had 10 crashes. Thanks.
Flags: needinfo?(cchiorean)
Hi Marcia! Yes, we try to finish the work to this bug before the end of 63. I know Andrei did some research for these crashes, I'll NI him to give some updates.
Flags: needinfo?(cchiorean) → needinfo?(andrei.a.lazar)
This is related to https://bugzilla.mozilla.org/show_bug.cgi?id=1476424. I did some explanation there.
Flags: needinfo?(andrei.a.lazar)
It turns out when I did some digging, there are crashes in these signatures in 60 and 61 as well. They are not as visible since they all have different data parcel sizes and often end up at the bottom of the list as single crashes.

61 sample crash: https://crash-stats.mozilla.com/report/index/390461de-5eb6-474b-9d88-ca0490180814
62 sample crash: https://crash-stats.mozilla.com/report/index/912bd469-3a91-4993-89a4-d4a650180816
https://bit.ly/2MnmTyt shows over 50 crashes in the last 7 days on 63 nightly.
To be honest, I still couldn't reproduce this. The best I can get at this point is a speculative fix. I really need some STR for this.
I will check to see if I can get any URLs. From what I can see, none of the reports have comments.
Crash Signature: android.os.BinderProxy.transactNative(Native Method)] → android.os.BinderProxy.transactNative(Native Method)] [@ android.os.TransactionTooLargeException: data parcel size 1348908 bytes at android.os.BinderProxy.transactNative(Native Method)]
Whiteboard: --do_not_change--[priority:high]
(In reply to Marcia Knous [:marcia - needinfo? me] from comment #11)
> Here are a few URLs I pulled out from various branches:
> 
> *https://zo.imikimi.com/post/5s7PEkLRGrGv/GailHudson/BettyBoop
> *http://www.newtonapples.net/PDF417_demo/USBcam_demo.html
> *https://qalam.withgoogle.com/ar-ae/create/
> ?gclid=EAIaIQobChMI06fl9Mv83AIVlTrgCh3A2AsyEAEYASAAEgKHOPD_BwE
> *view-source:https://web.facebook.com/login/
> *https://www.creditonebank.com/transactional/documents-statements
> 
> Adding Ioana in case someone can try reproducing with some of those URLs.

Tried together with Andrei on these devices but we did not see anything:
Google Pixel 2 Android P
Samsung Galaxy S8 Android 8.0.0
Sony Xperia XZ Android 7.0
Samsung, Galaxy S8+ Android 8.0.0 
Google Pixel XL Android P
Flags: needinfo?(ioana.chiorean)
Marcia, after much time and consultation, the best we have on this is a speculative fix. Should we make that speculative fix with the hopes the issue is addressed?
Flags: needinfo?(mozillamarcia.knous)
(In reply to :sdaswani only needinfo from comment #13)
> Marcia, after much time and consultation, the best we have on this is a
> speculative fix. Should we make that speculative fix with the hopes the
> issue is addressed?

Now that we are on 64 I think it wouldn't hurt to try. This continues to average about 50+ crashes every 7 days, with crash count per day varying from 12+ crashes. As far as devices, I see the Samsung Galaxy S8 among the device mix, as well as some others that aren't as common.
Flags: needinfo?(mozillamarcia.knous)
Mozilla Version 64.0a1 is unusable on Android 8.0.0 running on OnePlus3 with latest Window Manager OxygenOS 5.0.5. The symptom is that when Firefox Nightly is invoked by tapping app, the icon takes on a milky haze for about 1-sec and then reverts but the app itself is not brought up. This has been happening for the past 2-wks or so. I had to switch to Firefox Beta Android client as a workaround.
Andrei can you try the speculative fix?

Also Andrei can you reproduce this? https://bugzilla.mozilla.org/show_bug.cgi?id=1480852#c15
Flags: needinfo?(andrei.a.lazar)
Sure I will post a speculative fix asap and I tried to reproduce the comment #15 on OnePlus6 with no success.
Flags: needinfo?(andrei.a.lazar) → needinfo?(sdaswani)
Also unable to reproduce steps from Comment 11 and Comment 15 on OnePlus 3 (Android 6.0.1).
Thanks, please post a speculative fix.
Flags: needinfo?(sdaswani)
Added an extra check of bundle size due to some unexpected transactions sizes that exceed the limit.
The bundle gets lighter if the size exceeds the limit by removing the views' state as a last resort.
Comment on attachment 9008463 [details]
Bug 1480852 Crash in android.os.TransactionTooLargeException: data parcel size 1053364 bytes at android.os.BinderProxy.transactNative(Native Method) r=sdaswani

Jim Chen [:jchen] [:darchons] has approved the revision.
Attachment #9008463 - Flags: review+
Keywords: checkin-needed
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/55712e533027
Crash in android.os.TransactionTooLargeException: data parcel size 1053364 bytes at android.os.BinderProxy.transactNative(Native Method) r=jchen
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/55712e533027
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Ryan this bug is tracking 63 - should it be uplifted to Beta?
Flags: needinfo?(ryanvm)
Yes, a Beta uplift request would be great here.
Flags: needinfo?(ryanvm) → needinfo?(andrei.a.lazar)
Vlad can you  uplift this today?
Flags: needinfo?(andrei.a.lazar) → needinfo?(vlad.baicu)
Comment on attachment 9008463 [details]
Bug 1480852 Crash in android.os.TransactionTooLargeException: data parcel size 1053364 bytes at android.os.BinderProxy.transactNative(Native Method) r=sdaswani

Approval Request Comment
[Feature/Bug causing the regression]: IPC transaction buffer exceeded but the exact cause/scenario remains unknown
[User impact if declined]: Considerable crash rate
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Unable to reproduce
[List of other uplifts needed for the feature/fix]: -
[Is the change risky?]: Low
[Why is the change risky/not risky?]: At the very least, the state of the views are dropped as a last resort instead of having the app crash.
[String changes made/needed]: -
Flags: needinfo?(vlad.baicu)
Attachment #9008463 - Flags: approval-mozilla-beta?
Comment on attachment 9008463 [details]
Bug 1480852 Crash in android.os.TransactionTooLargeException: data parcel size 1053364 bytes at android.os.BinderProxy.transactNative(Native Method) r=sdaswani

Uplift approved for 63 beta 8, thanks.
Attachment #9008463 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I did a quick search today, and it looks as if on Fennec nightly we still have instances of this crash, with different data parcel sizes, after the landing on 9-14: https://bit.ly/2MKRkdi. I realize that this was a speculative fix, so just mentioning since this was uplifted to beta.
I wasn't able to reproduce the issue with Nikia 6 (Android 7.1.1), OnePlus 5T (Android 8.1.0) and Samsung Galaxy S8 (Android 8.0) on the latest version of Nightly 64.0a1 (2018-09-25) and Beta 63.0b9. Used several scenarios in the same links mentioned by Marcia.
No longer blocks: 1496435
You need to log in before you can comment on or make changes to this bug.