Closed Bug 1496435 Opened Last year Closed 11 months ago

Crash in android.os.TransactionTooLargeException: data parcel size 1006396 bytes at android.os.BinderProxy.transactNative(Native Method)

Categories

(Firefox for Android :: General, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1503255
Tracking Status
firefox64 --- affected

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-cef66d02-abfe-46ca-a7f0-a53b90181003.
=============================================================

We have made several attempts to fix these crashes, but as I noted in Bug 1480852#c30 they are still occurring on nightly: https://bit.ly/2IChPkL. It looks as if in 7 day period we have about 50 crashes, all with different data parcel sizes.

Java stack trace:

android.os.TransactionTooLargeException: data parcel size 1006396 bytes
	at android.os.BinderProxy.transactNative(Native Method)
	at android.os.BinderProxy.transact(Binder.java:748)
	at android.app.IActivityManager$Stub$Proxy.activityStopped(IActivityManager.java:4646)
	at android.app.ActivityThread$StopInfo.run(ActivityThread.java:4119)
	at android.os.Handler.handleCallback(Handler.java:789)
	at android.os.Handler.dispatchMessage(Handler.java:98)
	at android.os.Looper.loop(Looper.java:231)
	at android.app.ActivityThread.main(ActivityThread.java:6749)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.Zygote$MethodAndArgsCaller.run(Zygote.java:240)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:767)
I am going to dupe this to the meta bug, as we will continue investigation of this signature in that bug.
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1503255
You need to log in before you can comment on or make changes to this bug.