Switch Linux Nightlies and PGO builds to clang

RESOLVED FIXED in Firefox 64

Status

defect
RESOLVED FIXED
10 months ago
6 months ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla64
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 64+, firefox64 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Assignee

Description

10 months ago
No description provided.
Assignee

Updated

10 months ago
Summary: Switch Nightlies and PGO builds to clang → Switch Linux Nightlies and PGO builds to clang
Assignee

Updated

10 months ago
Depends on: 1484897
Assignee

Comment 1

10 months ago
And enable LTO on CI builds using clang + PGO.
Attachment #9003023 - Flags: review?(core-build-config-reviews)

Updated

10 months ago
Attachment #9003023 - Flags: review?(core-build-config-reviews) → review+
Assignee

Updated

10 months ago
Depends on: 1485556
Assignee

Updated

10 months ago
Depends on: 1482268
Assignee

Updated

10 months ago
Depends on: 1485562
Assignee

Comment 2

10 months ago
Updated to avoid busting artifact builds (and probably l10n) with "mozbuild.configure.options.InvalidOptionError: LLVM_PROFDATA is not available in this configuration" errors. Carrying over r+.
Attachment #9003023 - Attachment is obsolete: true
Attachment #9003386 - Flags: review+
Assignee

Updated

10 months ago
Depends on: 1487622
Assignee

Updated

9 months ago
Depends on: 1488587
Assignee

Comment 3

9 months ago
And enable LTO on CI builds using clang + PGO.
Assignee

Updated

9 months ago
Attachment #9003386 - Attachment is obsolete: true
Attachment #9006406 - Attachment description: Bug 1481721 - Switch Linux nightlies and PGO builds to clang. → Bug 1481721 - Switch Linux nightlies and PGO builds to clang. r?build
Assignee

Comment 4

9 months ago
I uploaded all the old versions of the patch to phabricator, and pushed the last updates to actually fix the artifact/l10n builds problem mentioned in comment 2 and to adapt to changes from bug 1486998.
Comment on attachment 9006406 [details]
Bug 1481721 - Switch Linux nightlies and PGO builds to clang

Nathan Froyd [:froydnj] has approved the revision.
Attachment #9006406 - Flags: review+
Assignee

Updated

9 months ago
Depends on: 1490218
Attachment #9006406 - Attachment description: Bug 1481721 - Switch Linux nightlies and PGO builds to clang. r?build → Bug 1481721 - Switch Linux nightlies and PGO builds to clang

Comment 6

9 months ago
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/23860890d959
Switch Linux nightlies and PGO builds to clang r=froydnj
Assignee

Updated

9 months ago
Duplicate of this bug: 1464193
Assignee

Updated

9 months ago
Blocks: 1490542

Comment 8

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/23860890d959
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Assignee

Updated

9 months ago
Blocks: 1490549
perf improvements:
== Change summary for alert #15834 (as of Wed, 12 Sep 2018 02:54:15 GMT) ==

Improvements:

 13%  tp5o responsiveness linux64 pgo e10s stylo                0.68 -> 0.59
 13%  displaylist_mutate linux64 pgo e10s stylo                 2,122.70 -> 1,857.24
 10%  perf_reftest_singletons linux64 pgo e10s stylo            47.40 -> 42.62
  9%  speedometer linux64 pgo e10s stylo                        78.89 -> 86.14
  9%  about_preferences_basic linux64 pgo e10s stylo            154.50 -> 140.54
  8%  tp5o_webext linux64 pgo e10s stylo                        200.79 -> 185.24
  7%  a11yr linux64 pgo e10s stylo                              189.58 -> 175.45
  7%  dromaeo_dom linux64 pgo e10s stylo                        3,245.74 -> 3,471.69
  7%  ts_paint_webext linux64 pgo e10s stylo                    205.50 -> 192.08
  6%  tp5o_webext responsiveness linux64 pgo e10s stylo         1.26 -> 1.18
  6%  tsvgx linux64 pgo e10s stylo                              180.21 -> 169.47
  6%  tsvg_static linux64 pgo e10s stylo                        69.29 -> 65.21
  6%  tart linux64 pgo e10s stylo                               2.06 -> 1.95
  5%  tp5o linux64 pgo e10s stylo                               129.52 -> 122.46
  4%  tscrollx linux64 pgo e10s stylo                           0.68 -> 0.65
  4%  sessionrestore linux64 pgo e10s stylo                     336.00 -> 323.67
  4%  sessionrestore_no_auto_restore linux64 pgo e10s stylo     356.25 -> 343.50
  3%  tp5o_scroll linux64 pgo e10s stylo                        0.59 -> 0.57

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=15834
This is in 64 release notes as, "Improved performance for Mac and Linux users, by enabling link time optimization (Clang LTO). (Clang LTO was enabled for Windows users in Firefox 63.)" (along with enabling LTO for Mac in bug 1473786).
You need to log in before you can comment on or make changes to this bug.