PhabBot changes are showing up as from the wrong user, and also sending email incorrectly (based on the wrong current user)

RESOLVED FIXED

Status

()

defect
P1
normal
RESOLVED FIXED
11 months ago
10 months ago

People

(Reporter: dylan, Assigned: dylan)

Tracking

({conduit-triaged})

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments, 1 obsolete attachment)

11:02 <Standard8> So I’m reviewing someone’s patchset, and I’m getting bugmail notifications saying that the other person has changed the bug, even though the comment is from myself.
11:02 <Standard8> Is that bugzilla or phab?
11:02 <Standard8> i.e. where should I file the bug
11:04 <Standard8> there’s kinda two bugs here, but maybe only one: 1) I’m getting email for stuff I’m doing. 2) the email is wrong (foo changed bug xxx….. comment on bug xxx from Me!)
Posted file badreviewemail.eml
This is one of the unexpected emails I got.

Paolo is the person that requested the review, and I reviewed it.

So I shouldn't have received the email, but in any case, it was myself that changed the bug, not Paolo.
Just to note, the original requester didn't get the bugmail.
Keywords: conduit-triaged
Priority: -- → P1
Assignee: nobody → dkl
Status: NEW → ASSIGNED
FWIW this bug 1482145 when landed should fix this issue and probably other related issues. I want to do some extensive testing first before putting it up for review.
Posted file github pr #709 (obsolete) —
Assignee: dkl → dylan
Duplicate of this bug: 1483848
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
I'm still seeing issues like this, ie this change: https://bugzilla.mozilla.org/show_bug.cgi?id=1483167#c6 got me a bugzilla email that said Drew changed the bug. Drew requested review, but I granted it, so the email is wrong, but the bug comment is correct.

Is that being fixed here, and just not deployed yet? Or should I file a new bug, and if so, is that a bugzilla bug or a phabricator bug?
Flags: needinfo?(dylan)
(In reply to :Gijs (he/him) from comment #11)
> I'm still seeing issues like this, ie this change:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1483167#c6 got me a bugzilla
> email that said Drew changed the bug. Drew requested review, but I granted
> it, so the email is wrong, but the bug comment is correct.
> 
> Is that being fixed here, and just not deployed yet? Or should I file a new
> bug, and if so, is that a bugzilla bug or a phabricator bug?

Yes the fix has been committed but not yet deployed. It should be going live soon.

dkl
Flags: needinfo?(dylan)
Duplicate of this bug: 1488297
Duplicate of this bug: 1487805
You need to log in before you can comment on or make changes to this bug.