Closed Bug 1482220 Opened 2 years ago Closed 2 years ago

Figure out why add/edit form strings don't appear on Nightly builds

Categories

(Firefox :: WebPayments UI, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox63 --- verified

People

(Reporter: MattN, Assigned: MattN)

Details

(Whiteboard: [webpayments])

Attachments

(4 files)

This is probably a packaging issue or race condition. Probably need to do a package build and see if the problem reproduces there locally to eliminate that option. It could also be a race related to the l10n.js file.

Hani, have you been seeing this problem in your testing?
Flags: qe-verify+
Hani, has your team seen this issue during testing?
Flags: needinfo?(hani.yacoub)
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: [webpayments] [triage] → [webpayments-reserve]
Attached image strings.png
If you are referring to the field labels as in this screenshot attached (strings.png) where only "State" and "ZIP Code" are displayed.
Yes, we were aware if this issue, but we assumed that it's going to be handled later on since it's very obvious.
I should have brought that up in our meetings.
Flags: needinfo?(hani.yacoub)
The issue seems to be a race and I think only happens on packaged builds because the edit forms load after the DOMContentLoaded of the dialog in that case. I don't know why because unfortunately our developer tools are useless for debugging this :( The other issues was because I don't think I realized that the attribute observer notification wouldn't get called when nodes are appended. Rather than waste another day figuring out the underling "why?" of the race, I made a patch to workaround it since the whole l10n.js file will get removed once we switch to Fluent (as is mentioned in the comment of that file).

(In reply to Hani Yacoub from comment #2)
> Yes, we were aware if this issue, but we assumed that it's going to be
> handled later on since it's very obvious.

Oh ok, well unfortunately the problem only happened on Nightlies, not out local developer builds, so we didn't notice the problem.
Whiteboard: [webpayments-reserve] → [webpayments]
Comment on attachment 9002628 [details]
Bug 1482220 - Listen for the autofill edit forms being appended for localization. r=sfoster

Sam Foster [:sfoster] has approved the revision.
Attachment #9002628 - Flags: review+
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/865339e90f1a
Listen for the autofill edit forms being appended for localization. r=sfoster
https://hg.mozilla.org/mozilla-central/rev/865339e90f1a
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Attached image exp.png
Verified that all the add/edit form strings are displayed now on Firefox Nightly 63.0a1 on Windows 10 x 64, Windows 7 x32, Mac OS X 10.13 and Ubuntu 18.04 x64.

I noticed that in the Add/Edit Credit Card form (Exp.Month and Exp.Year) strings aren't displayed inside the field. See the screenshot attached(exp.png)
Should I log a new bug for this or it is handled in another bug?
Flags: needinfo?(MattN+bmo)
(In reply to Hani Yacoub from comment #8)
> Should I log a new bug for this or it is handled in another bug?

That was caused by bug 1477100 and is why I said in bug 1477100 comment 12 to hold off on verification of it. This will be fixed by bug 1480886 once the fields are in their proper positions so you don't need to file a bug for that.

Thanks!
Flags: needinfo?(MattN+bmo)
Thanks for the clarification! I'll mark this as Verified.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.