Closed Bug 1482334 Opened 2 years ago Closed 1 year ago

Tools -> Add-on Options not opening. Nothing in error console

Categories

(Thunderbird :: Add-Ons: General, defect, major)

All
macOS
defect
Not set
major

Tracking

(thunderbird_esr6063+ fixed, thunderbird63 wontfix, thunderbird64 fixed)

RESOLVED FIXED
Thunderbird 64.0
Tracking Status
thunderbird_esr60 63+ fixed
thunderbird63 --- wontfix
thunderbird64 --- fixed

People

(Reporter: abr, Assigned: aceman)

References

Details

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #1462923 +++

TB 60.0
macOS High Sierra 10.13.4 (17E202)



When I try to use the new "Tools -> Add-on Preferences" submenu with Thunderbird 60.0 under Mac OS X, it's not opening any of the configuration dialogs at all. I'm seeing six add-ons in that submenu, including a mix of old dialog-based-configuration ones and new tab-based-configuration ones, but selecting them from the menu does nothing. I've tried with all six, and all six don't work.

This does not appear to be generating any errors in the console.
Strange, I addressed this issue in bug 1419145 comment #59 and Richard tested it one comment before. It's even advertised as fixed in the release notes.

Richard, can you please test this again.
Flags: needinfo?(richard.marti)
macOS High Sierra too. Updated TB 52 to 60 and checked extensions updates -> all on actual stage. My "Before Tabs Toolbar" and Lightning are shown in the Add-ons menu and both open their pref dialogs. This profile has never seen a newer TB version than 52 until now, so this is a real life test.

Adam, you have Lightning too? And it shows no dialog?
Flags: needinfo?(richard.marti)
(In reply to Richard Marti (:Paenglab) from comment #2)
> macOS High Sierra too. Updated TB 52 to 60 and checked extensions updates ->
> all on actual stage. My "Before Tabs Toolbar" and Lightning are shown in the
> Add-ons menu and both open their pref dialogs. This profile has never seen a
> newer TB version than 52 until now, so this is a real life test.
> 
> Adam, you have Lightning too? And it shows no dialog?

That's right -- clicking on "Lightning" in the "Tools -> Add-on Preferences" menu does nothing for me.
Can you try in TB to press COMMAND+SHIFT+j, then clear all in this console and then try to open the Lightning pref. After this, are errors in the console? If yes, please copy and paste them into this bug.
(In reply to Richard Marti (:Paenglab) from comment #4)
> Can you try in TB to press COMMAND+SHIFT+j, then clear all in this console
> and then try to open the Lightning pref. After this, are errors in the
> console? If yes, please copy and paste them into this bug.

There's only one error, and it appears to be unrelated:

uncaught exception: 2147746065      autosync.js:206:13
Does it happen in new profile?
Flags: needinfo?(adam)
Summary: Tools -> Add-on Options not opening → Tools -> Add-on Options not opening. Nothing in error console
Component: Toolbars and Tabs → Add-Ons: General
(In reply to Wayne Mery (:wsmwk) from comment #6)
> Does it happen in new profile?

Sorry that it took me a while to get back to this.

Yes, the problem exists in a new profile.

I created a new profile and tried to open the preferences for Lightning. Nothing happened. No related console messages were generated.
Flags: needinfo?(adam)
Richard, can you test this again please. We're getting more reports of this.
Flags: needinfo?(richard.marti)
I tried my already installed extension, Before Tabs Toolbar, and it worked from tools menu and from AppMenu. Then I installed the in bug 1497501 mentioned extensions, Identity Chooser and Mail Merge. From AppMenu they work all the time, but when I try Identity Chooser from Tools menu, nothing happens. From now on no extension works from Tools menu. With deactivating my extension and reactivating (with restarts in between) BTT works again from Tools menu until I try Identity Chooser again.

I quick checked the install.rdf and saw no obvious error in it.
Flags: needinfo?(richard.marti)
I think the 2 menus should work basically the same, so if there would be a problem in install.rdf the addon would fail from both places.
Do you mean you click the addon prefs in the menu and nothing opens and from then on no addon options can be opened?
But is the "addon options" menu correctly populated with addons that have options? Or is that menu empty?
(In reply to :aceman from comment #12)
> I think the 2 menus should work basically the same, so if there would be a
> problem in install.rdf the addon would fail from both places.
> Do you mean you click the addon prefs in the menu and nothing opens and from
> then on no addon options can be opened?

Yes. I tried now more and ended now that also Lightning no more works over Tools. So more or less, now I can't open the extension prefs from tools anymore. :-(

No error visible in the console.

> But is the "addon options" menu correctly populated with addons that have
> options? Or is that menu empty?

Yes, it shows them correctly, also the icons.
(In reply to :aceman from comment #12)
> I think the 2 menus should work basically the same, ...
Is it the same code? The tools menu is not in the TB windows but comes from the Mac top toolbar (or whatever this is called) via OS integration, no?

The code is basically a hack :-(
https://hg.mozilla.org/releases/comm-beta/rev/0d6ed7a480beb8c00dc7b573f967265d433847d4#l1.38

Note that all that got ripped out again in TB 62:
https://hg.mozilla.org/comm-central/rev/fbbf9402b861#l1.41

But the hack seems to work since the menu *is* populated.
(In reply to Jorg K (GMT+2) from comment #14)
> (In reply to :aceman from comment #12)
> > I think the 2 menus should work basically the same, ...
> Is it the same code?
Code populating the menu and opening the dialogs is the same, search for initAddonPrefsMenu (3 occurrences).

> The tools menu is not in the TB windows but comes from
> the Mac top toolbar (or whatever this is called) via OS integration, no?

That is somehow done automatically by either OS X itself or the toolkit platform. We do not have any special handling for this in XUL.

> The code is basically a hack :-(
> https://hg.mozilla.org/releases/comm-beta/rev/
> 0d6ed7a480beb8c00dc7b573f967265d433847d4#l1.38
> 
> But the hack seems to work since the menu *is* populated.

Yes. The problem may be elsewhere.

Paenglab, can you somehow debug openAddonPrefs() which line does not get executed or if even execution gets into this function when the clicking on the menuitem does not work?
You could add a bunch of Services.console.logStringMessage("xxx"); or Cu.reportError("xxx"); - If you do, we need a patch that shows what you added to be able to correlate with the output.

Or we all make a trip to Switzerland and use Richard's Mac ;-)
Which only shows a black window because of the SDK issue. So no debugging possible. :-(
(In reply to :aceman from comment #15)
> (In reply to Jorg K (GMT+2) from comment #14)
> Paenglab, can you somehow debug openAddonPrefs() which line does not get
> executed or if even execution gets into this function when the clicking on
> the menuitem does not work?

Maybe you could start a try with the needed debug code. Builds from Mozilla still works.
That's what I was going to say. Aceman, local Mach builds don't work on macOS 10.14 due to some SDK issue. So could you prepare a patch with all the necessary debug to the error console, make sure locally that it shows the right thing and do a try build for Richard. On second thought, you could even to a debug build so Richard can check whether there's anything in the debug window.
But it should be a try on ESR.
OK, I'll prepare the patch.
When trying through tools menu to open the pref dialog without showing the dialog:

22:36:51.626 Clearing menu items  mailWindowOverlay.js:3731
22:36:51.627 Getting addons  mailWindowOverlay.js:3740
22:36:51.631 Creating menu items  mailWindowOverlay.js:3757
22:36:51.633 Done creating menu items  mailWindowOverlay.js:3781
22:36:58.420 ReferenceError: reference to undefined property "value"[Learn More]  messenger.xul:1:1
22:36:58.421 Entering openAddonPrefs  mailCore.js:503
22:36:58.421 Opening prefs dialog, with features=chrome,titlebar,toolbar,centerscreen,dialog=no  mailCore.js:512
22:36:58.431 Done opening prefs  mailCore.js:515

When opening through AppMenu with showing the dialog:

22:41:48.254 Clearing menu items  mailWindowOverlay.js:3731
22:41:48.254 Getting addons  mailWindowOverlay.js:3740
22:41:48.257 Creating menu items  mailWindowOverlay.js:3757
22:41:48.259 Done creating menu items  mailWindowOverlay.js:3781
22:41:53.023 Entering openAddonPrefs  mailCore.js:503
22:41:53.023 Opening prefs dialog, with features=chrome,titlebar,toolbar,centerscreen,dialog=no  mailCore.js:512
22:41:53.031 Done opening prefs  mailCore.js:515
With new build I get this (and dialog opens):

00:04:19.740 Clearing menu items  mailWindowOverlay.js:3731
00:04:19.741 Getting addons  mailWindowOverlay.js:3740
00:04:19.746 Creating menu items  mailWindowOverlay.js:3757
00:04:19.746 Creating menu item: addon=Before Tabs Toolbar; url=chrome://btt/content/settings.xul  mailWindowOverlay.js:3767
00:04:19.747 Creating menu item: addon=Lightning; url=chrome://messenger/content/preferences/preferences.xul  mailWindowOverlay.js:3767
00:04:19.748 Creating menu item: addon=Mail Merge; url=chrome://mailmerge/content/options.xul  mailWindowOverlay.js:3767
00:04:19.748 Done creating menu items  mailWindowOverlay.js:3782
00:04:21.315 Entering openAddonPrefs: url=chrome://btt/content/settings.xul ; optionstype=  mailCore.js:503
00:04:21.315 Opening prefs dialog, with features=chrome,titlebar,toolbar,centerscreen,dialog=no  mailCore.js:512
00:04:21.328 Done opening prefs  mailCore.js:515

So thumbs up. :-)
Sorry, I'm rushing this a bit since I have no patch to land right now. This looks right and is apparently working.
Assignee: nobody → jorgk
Attachment #9016560 - Flags: review+
Attachment #9016560 - Flags: approval-comm-beta+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/9b05b741a188
fix add-on options menu by replacing .value with .getAttribute('value') when opening add-on prefs. r=jorgk
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
Tried more with installing/removing other extensions and it still worked. :-)
Thanks, aceman.
Thanks for testing and administering the patch :)
Assignee: jorgk → acelists
Duplicate of this bug: 1500182
You need to log in before you can comment on or make changes to this bug.