Closed Bug 1482473 Opened 2 years ago Closed 2 years ago

Top search should be more like a button not a link

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.4 - Aug 20
Tracking Status
firefox62 --- verified
firefox63 --- verified

People

(Reporter: Mardak, Assigned: ursula)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The link href causes a status text to appear as well as allow context menu link behaviors, e.g., open in new tab.

We can just remove the href and style it to be cursor: pointer and any other things to make it look like other top site links.
Assignee: nobody → usarracini
Severity: normal → enhancement
Iteration: --- → 63.4 - Aug 20
Priority: P2 → P1
Blocks: 1482479
Commits pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/a7622b30ac34598135b17de0f7a56a9d31518616
Fix Bug 1482473 - Top search should be more like a button not a link

https://github.com/mozilla/activity-stream/commit/31d95e86c40ff8662806be99f242da704e0ea85c
Merge pull request #4318 from sarracini/bug_1482473

Fix Bug 1482473 - Top search should be more like a button not a link
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Blocks: 1482523
Blocks: 1482532
https://hg.mozilla.org/mozilla-central/rev/322c3cf43fe8
Target Milestone: --- → Firefox 63
Blocks: 1482398
I have verified that the issue is no longer reproducible in the latest Nightly (63.0a1, Build ID 20180815225731) on Windows 10, Mac 10.13 and Linux x64. The search Top Sites no longer show a website link at the bottom of the page, the context menu no longer has the option to open them in new tabs or windows.
Status: RESOLVED → VERIFIED
Verified on 62.0b18 over macOS 10.9, Ubuntu 16.04LTS, Win 10x64.
Same behaiour as in the comment above.
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.