Make the telephone number field required on the payer form if requestPayerPhone is true

VERIFIED FIXED in Firefox 65

Status

()

P1
normal
VERIFIED FIXED
7 months ago
5 months ago

People

(Reporter: MattN, Assigned: jaws)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

unspecified
Firefox 65
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 disabled, firefox64 disabled, firefox65 verified)

Details

(Whiteboard: [webpayments])

Attachments

(1 attachment, 2 obsolete attachments)

The asterisk should be shown and the save button should be disabled when it's missing. This may get fixed by bug 1481481.

The reason this field is special is because the telephone number isn't required on the billing or shipping address form AFAIK.
Flags: qe-verify+
QA Contact: hani.yacoub
Priority: -- → P3
Whiteboard: [webpayments] [triage] → [webpayments-reserve]
Duplicate of this bug: 1484677
Priority: P3 → P2
Whiteboard: [webpayments-reserve] → [webpayments]
Priority: P2 → P1
status-firefox63: --- → disabled
status-firefox64: --- → disabled
Attachment #9018068 - Attachment is obsolete: true
Attachment #9020414 - Attachment is obsolete: true

Comment 5

5 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2b6677a1d32d
Make the telephone number field required on the payer form if requestPayerPhone is true. r=MattN

Comment 6

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2b6677a1d32d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
status-firefox65: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65

Comment 7

5 months ago
Verified - fixed on the latest Nightly 65.0a1 (2018-11-02) (64-bit) on Windows 7/10, Mac OS 10.13. and Ubuntu 16.04.

The phone number is required only on the Payer Contact Forms. 
On the shipping/billing address forms, the phone number is not required - as expected.
Status: RESOLVED → VERIFIED
status-firefox65: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.