Certificate error pages' contents are no longer vertically centered (content is too far down)

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
9 months ago
9 months ago

People

(Reporter: jaws, Unassigned)

Tracking

({nightly-community})

Trunk
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 affected)

Details

Attachments

(1 attachment)

Posted image 2018-08-15_1428.png
+++ This bug was initially created as a clone of Bug #1476944 +++

I still experience this bug on Windows 10. See attached screenshot, on 63.0a1 (2018-08-15) (64-bit).
Flags: needinfo?(jhofmann)
Flags: needinfo?(guptatrisha97)
I think the content is centered *until you click "Continue..."*, right? (And then more content pops out below the centered main content)

This is notably less-bad than Bug 1476944, where the main content itself wasn't centered. (see right half of attachment 8993339 [details])
Put another way: it looks like the main content *is* vertically centered, as-expected (the "Warning" header down through the "Go Back" / "Continue" buttons).

And it remains in the same vertical position when you click "Continue" -- and as a result, the longer "continue"-appended content is biased to the bottom of the window.

This makes some sense (making the initial rendering nice & centered & having it not jump around when expanded) -- though it does feel a bit wasteful-of-screen-real-estate to have the top ~third of the window blank, with content protruding off the bottom & triggering a scrollbar, as shown in jaws' screenshot.
Yes, that is correct. I had forgotten that I clicked the "Continue" button before taking the screenshot. I can reproduce this with clicking the Continue button.

Yeah, even though the first container doesn't move when more content is displayed, it still feels odd that there is now wasted space at the top of the page when more content is displayed.
It looks the same for me on Debian. I quite like that the error message and "Continue" button do not jump around. And nothing is cut off.
OS: Windows 10 → All
Yeah, you already mentioned it, unfortunately (to my knowledge) there's no way to have both elements centered and avoid jumping around. This is not really a regression since the old error pages make the same compromise (and that was a conscious decision we made a while ago).

I'll close this bug as WONTFIX for now since I acknowledge that this behavior can look like a bug, but the alternative would be worse.

If anyone comes up with a better plan for this I'd be happy to make it happen!
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(jhofmann)
Flags: needinfo?(guptatrisha97)
Keywords: regression
Resolution: --- → WONTFIX
Duplicate of this bug: 1483185
You need to log in before you can comment on or make changes to this bug.