Various about: error pages' contents are no longer vertically centered (and instead are snapped to top) (about:tabcrashed, about:restartrequired, ...)

RESOLVED FIXED in Firefox 63

Status

()

defect
RESOLVED FIXED
10 months ago
8 months ago

People

(Reporter: dholbert, Assigned: trisha)

Tracking

({regression})

unspecified
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 unaffected, firefox63+ fixed)

Details

(Whiteboard: [good first verify])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

10 months ago
STR:
 1. Visit about:tabcrashed

EXPECTED RESULTS
Page content should be vertically centered.

ACTUAL RESULTS
Page content is not vertically centered -- it's just snapped to the top.


This is a recent regression, with this regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=b42a4a801685e9aa379c96b8741a4f03bc200da1&tochange=2835f9a114459f3328682b6301e2330783c350fc

...which just contains one commit:
https://hg.mozilla.org/integration/autoland/rev/2835f9a11445
trisha — Bug 1463755 - Update the design of certificate error pages r=johannh

It looks like that commit was meant to adjust one sort of error page, but it had fallout that broke other error pages (?)
(Reporter)

Updated

10 months ago
Flags: needinfo?(guptatrisha97)
(Reporter)

Comment 3

10 months ago
about:restartrequired is similarly broken (snapped to the top) in current Nightly, and was working (centered) 10 days ago.  I'm assuming it was broken by the same change.
Summary: about:tabcrashed page's content is no longer vertically centered → Various about: error pages' contents are no longer vertically centered (about:tabcrashed, about:restartrequired, ...)
(Reporter)

Updated

10 months ago
Duplicate of this bug: 1474386
Component: General → Theme
(Assignee)

Updated

10 months ago
Assignee: nobody → guptatrisha97
Flags: needinfo?(guptatrisha97)
(Assignee)

Updated

10 months ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

10 months ago
Posted patch bug1475025.patch (obsolete) — Splinter Review
Attachment #8992685 - Flags: review?(jhofmann)
Comment on attachment 8992685 [details] [diff] [review]
bug1475025.patch

Review of attachment 8992685 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, but you can also remove the captive portal adjustment now, I think: https://searchfox.org/mozilla-central/source/browser/base/content/aboutNetError.js#181

r=me with that fixed :)

Thanks!
Attachment #8992685 - Flags: review?(jhofmann) → review+
(Assignee)

Comment 7

10 months ago
Done, thanks!
Attachment #8992685 - Attachment is obsolete: true
(Assignee)

Updated

10 months ago
(Assignee)

Updated

10 months ago
Keywords: regression

Comment 8

10 months ago
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b28ca0001c8e
Vertically center the various error pages r=johannh
Keywords: checkin-needed

Comment 9

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b28ca0001c8e
Status: ASSIGNED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Depends on: 1476944
(Reporter)

Comment 10

10 months ago
[Clarifying summary to make it clearer how this differed from new bug 1476944 which is also about these pages' vertical centering]
Summary: Various about: error pages' contents are no longer vertically centered (about:tabcrashed, about:restartrequired, ...) → Various about: error pages' contents are no longer vertically centered (and instead are snapped to top) (about:tabcrashed, about:restartrequired, ...)
I have reproduced this bug with Nightly 63.0a1 (2018-07-11) on Windows 10, 64 Bit!
This bug's fix is verified with latest Nightly!

Build ID 	20180730100211
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
QA Whiteboard: [bugday-20180725]
Marking as GFV since it's an easy thing to verify.
Whiteboard: [good first verify]

Comment 13

8 months ago
The issue is no longer reproducible on Firefox 63.0b10 (build ID). Tests were performed under Windows 10x64,


[testday-20180928]
You need to log in before you can comment on or make changes to this bug.