Update webdriver to hyper 0.12

RESOLVED FIXED in Firefox 63

Status

defect
P1
normal
RESOLVED FIXED
10 months ago
9 months ago

People

(Reporter: eijebong, Assigned: eijebong)

Tracking

Trunk
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

10 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180817100105
Assignee

Updated

10 months ago
Component: Untriaged → geckodriver
Product: Firefox → Testing
Version: 63 Branch → Trunk
Assignee

Comment 1

10 months ago
MozReview-Commit-ID: G9aOKGHXgo

Bug 1484462 Part 2 - Revendor dependencies. r?ato

MozReview-Commit-ID: 7PFevFl7dGj
Assignee: nobody → eijebong
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
jgraham: You might want to be aware of this change.
Could we please wait with this change until I'm done with the Serde conversion on bug 1396821? A patch for that bug should be up today.
This change causes a panic at build time for me:
https://gist.github.com/andreastt/5b314a3545879bc37a2b785b221609dc
(In reply to Andreas Tolfsen ﹝:ato﹞ from comment #7)

> This change causes a panic at build time for me:
> https://gist.github.com/andreastt/5b314a3545879bc37a2b785b221609dc

OK, it seems that was the result of some bad build artefacts in the
object directory.  A clean build resolved the issue for me locally.
Comment on attachment 9003230 [details] [diff] [review]
0001-Bug-1484462-Part-1-Update-webdriver-to-hyper-0.12.-r.patch

Review of attachment 9003230 [details] [diff] [review]:
-----------------------------------------------------------------

r+ pending successful try run.
Attachment #9003230 - Flags: review?(ato) → review+
Attachment #9003231 - Flags: review?(ato) → review+
Comment on attachment 9003230 [details] [diff] [review]
0001-Bug-1484462-Part-1-Update-webdriver-to-hyper-0.12.-r.patch

Review of attachment 9003230 [details] [diff] [review]:
-----------------------------------------------------------------

::: Cargo.lock
@@ -69,4 @@
>  source = "registry+https://github.com/rust-lang/crates.io-index"
>  dependencies = [
>   "kernel32-sys 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
> - "libc 0.2.39 (registry+https://github.com/rust-lang/crates.io-index)",

Shouldn't the changes of this file be part of the vendoring patch?
(In reply to Henrik Skupin (:whimboo) from comment #10)
> Comment on attachment 9003230 [details] [diff] [review]
> 0001-Bug-1484462-Part-1-Update-webdriver-to-hyper-0.12.-r.patch
> 
> Review of attachment 9003230 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: Cargo.lock
> @@ -69,4 @@
> >  source = "registry+https://github.com/rust-lang/crates.io-index"
> >  dependencies = [
> >   "kernel32-sys 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)",
> > - "libc 0.2.39 (registry+https://github.com/rust-lang/crates.io-index)",
> 
> Shouldn't the changes of this file be part of the vendoring patch?

I prefer for them to be part of the first patch so they are possible
to review.
I had to do some rebasing and tweaking of the patches due to
https://bugzilla.mozilla.org/show_bug.cgi?id=1484941, but try was
green so I landed them on inbound.

Thanks eijebong!

Comment 14

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/738e47717e3f
https://hg.mozilla.org/mozilla-central/rev/03df1a267ea5
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Attachment #9002231 - Attachment is obsolete: false
Attachment #9002231 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.