Add "don't reply via e-mail" language to Bugzilla e-mails

VERIFIED FIXED

Status

()

bugzilla.mozilla.org
General
P3
enhancement
VERIFIED FIXED
16 years ago
7 years ago

People

(Reporter: Greg K., Assigned: justdave)

Tracking

Details

(Reporter)

Description

16 years ago
Please add some language to the top of Bugzilla e-mails specifying that
recipients reply by adding a comment to the bug in question rather than
attempting to reply diectly to Bugzilla or the previous respondent via return
e-mail.

This will hopefully dissuade novice users from sending unwanted e-mails to bug
triagers.

Such language might be something like this:

"ATTENTION: please do not reply to this bug via e-mail, either to Bugzilla or
the person who changed the bug. To respond, add your reply directly to the bug
in question. Thank you."
(Reporter)

Updated

16 years ago
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: Add no-reply language to Bugzilla e-mails → Add "don't reply via e-mail" language to Bugzilla e-mails
(Reporter)

Comment 1

16 years ago
*** Bug 151366 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

16 years ago
Severity: normal → enhancement
-> gerv
Assignee: endico → gerv
(Reporter)

Comment 3

15 years ago
Revised text suggestion: "ATTENTION: please do not reply to this message by
e-mail. To respond, add your 'Additional Comment' directly to the bug in
question. Thank you."
In our experience, people get irritated very quickly with additions to bugmail
which do not add function. The whole %reasonsbody% thing was an example of this.
We thought very hard about how to minimise the impact of the "configure bugmail"
addition. 

In that light, any message which begins "ATTENTION:" is definitely not
acceptable, unless there is some method of turning it off. My alternative
strategy was to do one of two things:

1) Set the Reply-To: address on bugmails to an invalid address which mail user
agents will flag up
or
2) Have an auto-responder on the From: address which says "Post in the bug, please."

Gerv

Gerv
The latter, please. that way people who don't care don't have to see this all
the time.
An auto-responder has to be set up on a per-installation basis (at the moment,
at any rate) - so if you want one for b.m.o., file a bug on mozilla.org/Server Ops.

Gerv
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
*** Bug 231114 has been marked as a duplicate of this bug. ***
This bug was wontfixed when Mozilla was still a very developer-centric
organization.  Now that we're catering to end-users, this is worth revisiting again.

RedHat's Bugzilla bugmail has this at the top of each:

-----
Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.
-----

It doesn't say "ATTENTION" and it's not very big.  I think that wording would
work, here, too.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
I remember how irritating %reasonsbody% was when it arrived on b.m.o. How about
a compromise - we add a section to the customisation part of the Bugzilla Guide
saying "You may want to add text to the param (hopefully soon to be template) to
tell people not to reply to emails."?

Gerv
This isn't for the Bugzilla project (anyone can already change the mail
templates and most people do).  This is for bugzilla.mozilla.org specifically.

I think there's too much whitespace at the top of the bugmails currently. 
Replace some of that whitespace with the above text, and we don't have any
vertical displacement, and we get a lot of benefit to all the new folks using
Bugzilla.
It's not about vertical displacement, though. It's about the irritation that
comes from reading text when you know exactly what it says, but can't stop
yourself reading it.

What's wrong with the autoresponder solution?

Gerv
An auto-responder seems like the right solution here.  It obtrudes only for whom
necessary, as opposed to for everyone.  We could also change "bugzilla-daemon"
to something like "post-to-bug-instead-of-replying", although that would
undoubtedly break enough mail filters that we should consider it only if an
auto-responder doesn't solve the problem effectively enough.
Autoresponders are a quick way to get us blacklisted by lots of the anti-spam
blacklists.

Someone only needs to "joe job" the responder address with a spam that's sure to
get bounced by lots of site's mail filters, our autoresponder than gleefully
replies to all of the bounces (blocked spam often comes from "postmaster" or the
like rather than <> like a real bounce) and people then report our autoreply as
spam.
Although I suppose we could train it to only reply to mail that has a bug number
in the subject...
Bug 153051 has suggested text.

Gerv
A quick scan of the apache mailbox on mecha shows that we get on average about
10 attempts per day to reply to bugmail.  (and 1400 bounces per day, but that's
another issue)

On September 23, there were almost exactly 1400 emails delivered to
apache@mecha.mozilla.org.  1375 of those were bounce notices.  10 were spam.  15
were people attempting to reply to bugmail.

Spotchecks of those 15 emails revealed that only 2 of the 15 had discovered
their reply never made it and re-posted their reply on the bug.

3 of the ones that didn't make it to the bug were the reporter replying to
UNCONFIRMED bugs stating that the problem had been solved, and the bug could be
closed.  1 of those bugs had been resolved as a duplicate already.  The other
two were still open.

An auto-reply is not user friendly at all.  Especially if we didn't warn them in
the bugmail.

I think our best option long-term is to get the real inbound email support in
Bugzilla (Joel came up with the idea of using SRS authentication for it, so we
could verify that the message was a reply to a bugmail and to whom the message
they replied to was sent).

Short term I think we're better off adding a line to the top of the bugmail
stating that you can't reply to it.  My suggested text:

==================
Please do not reply to this email.  You can add comments at
(url goes here)
==================

That adds ONE line to the email (the URL is already there), and since it's the
very first thing in the email, I'm willing to bet most people who are used to
Bugzilla won't even notice it's there because they're used to skipping over the
URL except when they're about to click on it.  The people who've never seen
Bugzilla bugmail before will probably see it.
I dread inbound email support, because I strongly suspect we'll end up with
serious issues with comment bloat caused by lack of trimming. But that's another
issue too :-)

Let's add the line on b.m.o. and see what reaction is like.

Gerv
Assignee: gerv → justdave
Blocks: 280371
Status: REOPENED → NEW
Priority: -- → P3
(In reply to comment #17)

> Let's add the line on b.m.o. and see what reaction is like.

Done.  (prompted by Jesse's comments in bug 153051)
Status: NEW → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 19

13 years ago
Belatedly VERIFIED using TB 1.5.
Status: RESOLVED → VERIFIED
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.