Closed Bug 1487337 Opened 5 years ago Closed 4 years ago

Bump WebIDE "connecting to old, unsupported runtime" warning message to current version minus two (ie. 62 today)

Categories

(DevTools Graveyard :: WebIDE, enhancement, P3)

enhancement

Tracking

(firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Bug 1405008 originally introduced a warning in WebIDE to tell the user when connecting to an old, unsupported remote, it may break at any time.

At that time we chose to start displaying this warning when connecting to something older than current ESR version, which was 52.

It looks like we have now release ESR 60. It isn't clear if that's the new official ESR or still a candidate?

It looks like when Firefox 62 will be release 60 will get out of the "qualify" and be the new ESR:
  https://www.mozilla.org/en-US/firefox/organizations/

Should we bump our threshold once 62 is released?
That's my understanding as well, we can bump this when 62 hits release (so 5th of september)
Priority: -- → P3
Severity: normal → enhancement
Updating the title to follow discussion from the RFC:
https://github.com/devtools-html/rfcs/issues/51

We would now open such bug and bump the value on the beginning of each new nightly cycle.

Now the precise threshold may still be discussed.
"3 versions before" may mean two different releases:
* 64-3 = 61
* or whatever is the current release version = 62

Supporting Version-3 helps debugging phones that do not immediately update Firefox...
Summary: Bump WebIDE "connecting to old, unsupported runtime" warning message to ESR60 → Bump WebIDE "connecting to old, unsupported runtime" warning message to 61
Blocks: 1405007
Given that I heard no-one about the precise version, I went for 62, the current release channel's version.

I don't particularly maintain my android phone and my firefox is already updated to 62,
so I'm expecting us to only test against the current release and not the previous one.
I would expect the same to happen to web developers.
See Also: → 1492460
Comment on attachment 9010229 [details]
Bug 1487337 - Bump devtools compatibility threshold up to 62 (current release version) r=jdescottes

Julian Descottes [:jdescottes][:julian] has approved the revision.
Attachment #9010229 - Flags: review+
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8842e929c30f
Bump devtools compatibility threshold up to 62 (current release version) r=jdescottes
https://hg.mozilla.org/mozilla-central/rev/8842e929c30f
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Summary: Bump WebIDE "connecting to old, unsupported runtime" warning message to 61 → Bump WebIDE "connecting to old, unsupported runtime" warning message to current version minus two (ie. 62 today)
Assignee: nobody → poirot.alex
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.