Closed Bug 1487496 Opened Last year Closed Last year

Dropdown marker is blurred, if disabled state

Categories

(Firefox :: Preferences, defect, P1)

63 Branch
x86_64
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 - verified

People

(Reporter: alice0775, Assigned: Paolo)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
[Tracking Requested - why for this release]:

Reproducible : always

Steps To Reproduce:
1. Open about:preferences#privacy


Actual Results:
Dropdown marker is blurred. See attached Screenshot.

Expected Results:
not blurred
Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=972b64c9061501955b056adcb71e96b6f4b83abd&tochange=20db845c4c8708965992adfadc737ff094b6e677

Regressed by: 20db845c4c87	Paolo Amadini — Bug 1457216 - Remove support for editable menulists. r=surkov,bgrins
Blocks: 1457216
I haven't done any bisecting to see why this would be caused by Bug 1457216, but it seems like disabled dropmarkers get a list-style-image of chrome://global/skin/arrow/arrow-dn-dis.gif [0] which overrides the in-content list-style-image chrome://global/skin/in-content/dropdown.svg") [1].

That gif is 5x3px on Windows/Linux and 11x11px on OSX, so I think that's why it's getting stretched. Seems like if nothing else then for in-content styles we could override the fill color on the svg rather than changing the list-style-image.

[0]: https://searchfox.org/mozilla-central/rev/2fe43133dbc774dda668d4597174d73e3969181a/toolkit/themes/osx/global/dropmarker.css#20
[1]: https://searchfox.org/mozilla-central/rev/2fe43133dbc774dda668d4597174d73e3969181a/toolkit/themes/shared/in-content/common.inc.css#386
Flags: needinfo?(paolo.mozmail)
Flags: needinfo?(paolo.mozmail)
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Priority: -- → P1
Comment on attachment 9005579 [details]
Bug 1487496 - Dropdown marker is blurred when disabled. r=dao

Dão Gottwald [::dao] has approved the revision.
Attachment #9005579 - Flags: review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3050ceae2cbb
Dropdown marker is blurred when disabled. r=dao
Blocks: 1487765
https://hg.mozilla.org/mozilla-central/rev/3050ceae2cbb
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
I have managed to reproduce this issue on an affected Firefox 63.0a1 (20180830220110) build using Windows 10x64 by following the STR from comment 0. 

This issue is verified fixed using Firefox 63.0b4 (20180906162647) on the following OSes: Windows 10 x64, mac 10.13.6, Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.