Closed Bug 1488310 Opened Last year Closed Last year

"Change block list" (text-link) in "about:preferences#privacy" is shown double

Categories

(Firefox :: Preferences, defect)

63 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1488436
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- fixed
firefox64 --- fixed

People

(Reporter: suishouen, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image screenshot.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180903221928

Steps to reproduce:

1. Open "about:preferences#privacy"
2. See "All Detected Trackers" section


Actual results:

"Change block list" (text-link) is shown double


Expected results:

"Change block list" (text-link) shuld not be shown double.
Seems to be regressed by: Bug 1488013
Blocks: 1488013
Has STR: --- → yes
Component: Untriaged → Preferences
Flags: needinfo?(ehsan)
Keywords: regression
"view-source:about:preferences#privacy" contains as follws:
I think this seems to cause the issue.

---
<label id="changeBlockListLink" data-l10n-id="content-blocking-tracking-protection-change-block-list" class="text-link"/>
              <label id="changeBlockListLink"
                     data-l10n-id="content-blocking-tracking-protection-change-block-list"
                     class="text-link"
                     search-l10n-ids="blocklist-window.title, blocklist-desc, blocklist-button-cancel.label, blocklist-button-ok.label"/>
---
Depends on: 1488361
No longer blocks: 1488013
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Flags: needinfo?(ehsan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1488436
No longer depends on: 1488361
You need to log in before you can comment on or make changes to this bug.