Add a title to each section in about:addons

RESOLVED FIXED in Firefox 64

Status

()

enhancement
P2
normal
RESOLVED FIXED
8 months ago
a month ago

People

(Reporter: emanuela, Assigned: mstriemer)

Tracking

(Depends on 1 bug, Blocks 1 bug)

unspecified
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 months ago
Add a section title to the extensions' area in about:addons.

String: Manage your extensions

The title will have the same visual style of the Preference header title (class in use 'header-name'). Re-use Preference's class should give us already all the correct spacing.

Attach to this bug you find a screen that shows the final state. Please note that this picture shows a series of different improvements relevant to other bugs.
Blocks: 1489296
Assignee: ddurst → mstriemer
Priority: -- → P2
(Assignee)

Updated

7 months ago
Duplicate of this bug: 1488736
(Assignee)

Comment 2

7 months ago
The easiest way to do this is to provide a title for each section.
Summary: Add a section title to the extensions' area in about:addons. → Add a title to each section in about:addons

Comment 4

6 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4d076c865471
Add a heading to about:addons sections r=aswan
(Assignee)

Comment 6

6 months ago
There was a bad rebase and a test change that should've been earlier in the series causing these failures. I'm running another try build now, but looks to be fixed and will re-land.
Flags: needinfo?(mstriemer)

Comment 7

6 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4420c564868c
Add a heading to about:addons sections r=aswan

Comment 8

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4420c564868c
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
(Assignee)

Updated

a month ago
Depends on: 1535915
You need to log in before you can comment on or make changes to this bug.