Convert about:addons pages to the card styles

VERIFIED FIXED in Firefox 64

Status

()

P2
normal
VERIFIED FIXED
7 months ago
3 months ago

People

(Reporter: mstriemer, Assigned: mstriemer)

Tracking

(Blocks: 1 bug)

unspecified
mozilla64
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 verified, firefox65 verified)

Details

Attachments

(4 attachments)

(Assignee)

Description

7 months ago
There are shared card styles for the keyboard shortcuts now. They work fairly well on the listing pages and are a nice improvement.

Once bug 1303384 is landed, we should update the listing pages to match the same style.
I'm not seeing the pointer-events hack we talked about. Are you still going to implement that or did you find an alternative?
Flags: needinfo?(mstriemer)
(Assignee)

Comment 5

6 months ago
I partially worked around it with CSS, it still isn't perfect, but good enough I think. The pointer-events hack didn't really work combined with the fix for the width of the richlistbox since you could only scroll while your mouse was over a richlistitem.
Flags: needinfo?(mstriemer)
Blocks: 1495713

Comment 6

5 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7e0abd16a50b
Part 1: Move card styles to common from about:debugging r=dao
https://hg.mozilla.org/integration/autoland/rev/448672780572
Part 2: Convert about:addons to card UI r=aswan,jaws
https://hg.mozilla.org/integration/autoland/rev/0b8bcd97f254
Part 3: Select the first item in richlistbox on focus r=dao
(Assignee)

Comment 8

5 months ago
There was a bad rebase and a test change that should've been earlier in the series causing these failures. I'm running another try build now, but looks to be fixed and will re-land.
Flags: needinfo?(mstriemer)

Comment 9

5 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a19f3794f0c9
Part 1: Move card styles to common from about:debugging r=dao
https://hg.mozilla.org/integration/autoland/rev/cb62a8b8a525
Part 2: Convert about:addons to card UI r=aswan,jaws
https://hg.mozilla.org/integration/autoland/rev/0a45a5634cf1
Part 3: Select the first item in richlistbox on focus r=dao

Comment 10

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a19f3794f0c9
https://hg.mozilla.org/mozilla-central/rev/cb62a8b8a525
https://hg.mozilla.org/mozilla-central/rev/0a45a5634cf1
Status: NEW → RESOLVED
Last Resolved: 5 months ago
status-firefox64: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla64

Updated

5 months ago
Depends on: 1499103

Updated

5 months ago
Depends on: 1499109

Comment 11

5 months ago
Hi, what is part 3 about?
Does it mean that there will always be at least one item selected?
I thought in a seltype="multiple" it is possible to have no selection and no currentIndex.
See https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XUL/richlistbox .

There does not seem to be any explanation in this bug.
Thanks.
Flags: needinfo?(mstriemer)

Updated

5 months ago
Depends on: 1499294

Updated

5 months ago
Depends on: 1499345
(Assignee)

Comment 12

5 months ago
The currentIndex path hasn't changed, so I'm thinking not having a currentIndex was not possible before. Without part 3 focusing the richlistbox wouldn't mark a child as selected but pressing DownArrow to move to the first item would move to the second since currentIndex was already 1.

If you don't think this is how it should work can you please file a new bug and explain why you think it should change?
Flags: needinfo?(mstriemer)
(Assignee)

Updated

5 months ago
Summary: Convert about:addons listing pages to the card styles → Convert about:addons pages to the card styles
(Assignee)

Updated

5 months ago
Duplicate of this bug: 1496070

Comment 14

5 months ago
Thanks, right. currentIndex was forced to other than -1 even before the patch, you just make the selection match the currentItem.

Updated

5 months ago
Depends on: 1500004

Updated

5 months ago
Depends on: 1500010

Updated

5 months ago
Depends on: 1500164

Updated

5 months ago
Depends on: 1500165

Updated

5 months ago
Depends on: 1500193

Updated

5 months ago
Depends on: 1500685

Comment 15

5 months ago
Posted image Bug1490366.gif
I was able to reproduce this issue on Firefox 62.0.3(20181001155545) under Win 7 64-bit and  Mac OS X 10.13.3.

This issue is verified as fixed on Firefox 65.0a1(20181022220734) and Firefox 64.0b3 (20181022150107) under Win 7 64-bit and Mac OS X 10.13.3.

Please see the attached video.

Updated

5 months ago
Status: RESOLVED → VERIFIED
status-firefox64: fixed → verified
status-firefox65: --- → verified

Updated

3 months ago
Depends on: 1516768
You need to log in before you can comment on or make changes to this bug.