polygons not drawn or visible edges with Firefox 62

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 months ago
7 months ago

People

(Reporter: aryx, Unassigned)

Tracking

({regression})

unspecified
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62+ fixed, firefox63+ fixed, firefox64+ fixed)

Details

Attachments

(1 attachment)

Firefox 62.0 64-bit on Windows 8.1

https://skfb.ly/6BrUp has some polygons from the roof missing and one can see some gaps in the edges of the sides.

Bisection shows this started between 62.0 beta 18 and beta 19. Pushlog: https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=FIREFOX_62_0b18_RELEASE&tochange=FIREFOX_62_0b19_RELEASE

This looks like a regression from bug 1477817. Despite central (including beta 63) and ESR having also been patched, I am unable to reproduce this with those channels.

Comparison of the troubleshooting shows that the WebGL driver extensions additional have GL_KHR_robust_buffer_access_behavior in 62.0b19+
Flags: needinfo?(jgilbert)
Assuming this follows the same pattern of bug 1485441, there's a decent chance Beta63 will also reproduce, so setting the tracking flags accordingly. Also, fixed for 62.0.1 via backout.

https://hg.mozilla.org/releases/mozilla-release/rev/4e6207ecd553
Please post images showing the issue.
Flags: needinfo?(jgilbert) → needinfo?(aryx.bugmail)
Posted image polygon issues
Sorry, lost the attachment during bug creation when I had to go back in the tab's history and resubmit.
Flags: needinfo?(aryx.bugmail)
Fixing status flags.  Bug 1477817 was backed out of mozilla-release only.

Comment 5

8 months ago
The linked image shows what the model should look and what it looks like in FF6.2.

http://digital-mapping.net/Sketchfab/2018/Firefox62.jpg

Comment 6

8 months ago
I wrote FF6.2 in previous post, should be 62.0.

More info on this thread:
https://support.mozilla.org/en-US/questions/1232932#answer-1151942

Comment 7

8 months ago
(Sketchfab dev)

The problem seems to be specific to TRIANGLE_STRIPS on WEBGL1

https://sketchfab.com/models/7fd9a70e053a4fec922b436758707c5f
^ has the issue

https://sketchfab.com/models/7fd9a70e053a4fec922b436758707c5f?webgl2=1
^ works fine

https://sketchfab.com/models/7fd9a70e053a4fec922b436758707c5f?force_triangles=1
^ works fine

We might hotfix a temporary the issue by targeting firefox, a reliable url to reproduce the issue could be:
https://sketchfab.com/models/7fd9a70e053a4fec922b436758707c5f?force_triangles=0&webgl2=0

Comment 8

8 months ago
another sample site which shows some rendering defects according to a sumo report:
http://www.cadituk.com/satellite/C3D/cortona/MAC/2/test.htm
I can't reproduce the bug neither in Beta 63 nor Nightly 64 with the URLs provided in comments #7 and #8 (Linux).

Brindusa, could you investigate if this regression impacts 63 beta on all platforms? Thanks
Flags: needinfo?(brindusa.tot)

Comment 10

8 months ago
My bad, I went a bit too fast when fixing the bug on our side and forgot to respect the force_triangles=0 flag :(.

So, basically when we detect that we are on firefox, we convert our TRIANGLE_STRIPS to TRIANGLES (drawElements in both cases).

On next release (next week normally), I'll add back the force_triangles=0 enforcement for debugging purposes.

This bug report seems like a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1487847
My guess here is that ANGLE messes up index fetch when contexts are created with RBAB.

Comment 12

8 months ago
I've tested this and I couldn't reproduce the issue on Nightly 64 and Beta 63.
Environments covered: Win10 x64, Win8 x64, Ubuntu 16.04, MacOS 10.12
Flags: needinfo?(brindusa.tot)
This may be the same issue. 
This picture is of the error on Windows 10 64 bit:
http://service.mtdproducts.com/win10capture.JPG

Here is the same animation at the same point in time on a Window 7 64 bit machine:
http://service.mtdproducts.com/win7capture.JPG

For some reason it work on Windows 7 but not Windows 10.

Comment 14

8 months ago
(For information, we added back the ?force_triangles=0 debug option, I can confirm the url https://sketchfab.com/models/7fd9a70e053a4fec922b436758707c5f?force_triangles=0 reproduces the issue)
This should be fixed in firefox 62.0.2 which will ship in the next few days.

Updated

8 months ago
Duplicate of this bug: 1490248
Can anyone still reproduce this? (I guess not.)
Looks as expected with 62.0.3, 63.0b12 and latest Nightly, all on Windows 8.1 which also had been used to reproduce the issue in comment 0.
(In reply to Sebastian Hengst [PTO+workweek 2018-09-22 - 2018-10-08][:aryx] (needinfo on intermittent or backout) from comment #18)
> Looks as expected with 62.0.3, 63.0b12 and latest Nightly, all on Windows
> 8.1 which also had been used to reproduce the issue in comment 0.

Marking as fixed as a consequence, thanks.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.