Closed Bug 1491315 Opened Last year Closed Last year

Use new ADB extension in WebIDE

Categories

(DevTools Graveyard :: WebIDE, enhancement)

enhancement
Not set

Tracking

(firefox64 fixed)

RESOLVED FIXED
Firefox 64
Tracking Status
firefox64 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

References

Details

Attachments

(3 files)

We just released a test version of the new web-extension replacing ADBHelper: https://ftp.mozilla.org/pub/labs/fxos-simulator/adb-extension/

We should migrate WebIDE to use this extension instead of ADBHelper.
Depends on D5866

This re-enables a test that was disabled for a long time. The code
of the test is not the cleanest, but considering webIDE is going
away I prefer not too spend too much time on this.
Comment on attachment 9009116 [details]
Bug 1491315 - Use new ADB extension in WebIDE;r=hiro

Hiroyuki Ikezoe (:hiro) has approved the revision.
Attachment #9009116 - Flags: review+
I just noticed an annoying thing.  We should remove the old adb helper addon?
Comment on attachment 9009160 [details]
Bug 1491315 - Update webide addons test to use new adb-extension;r=daisuke

Daisuke Akatsuka (:daisuke) has approved the revision.
Attachment #9009160 - Flags: review+
Comment on attachment 9009162 [details]
Bug 1491315 - Rename all references to ADB Helper to ADB Extension;r=daisuke

Daisuke Akatsuka (:daisuke) has approved the revision.
Attachment #9009162 - Flags: review+
(In reply to Hiroyuki Ikezoe (:hiro) from comment #6)
> I just noticed an annoying thing.  We should remove the old adb helper addon?

Where should we remove it? We should still provide it on the FTP for old Firefox versions, but maybe you mean somewhere else?
Flags: needinfo?(hikezoe)
I mean we should remove the old addon from each users' profile (if there is), once after the new devtools-adb-extension is used for WebIDE. Otherwise the old addon persists on about:addons even if it's not used anymore, right?
Flags: needinfo?(hikezoe)
Ah that's a good point. Let's check if anything is planned to remove bootstrapped addons automatically from user profiles in 64 before rolling out a custom thing. I guess they will rather be disabled than completely uninstalled.

Andrew: since bootstrapped addons are removed after 64, will they be uninstalled automatically from user profiles or is this something we should take care of ourselves?
Flags: needinfo?(aswan)
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d7dbc25ebd37
Use new ADB extension in WebIDE;r=hiro
https://hg.mozilla.org/integration/mozilla-inbound/rev/eeaa726b6bf1
Update webide addons test to use new adb-extension;r=daisuke
https://hg.mozilla.org/integration/mozilla-inbound/rev/90483db905ac
Rename all references to ADB Helper to ADB Extension;r=daisuke
https://hg.mozilla.org/mozilla-central/rev/d7dbc25ebd37
https://hg.mozilla.org/mozilla-central/rev/eeaa726b6bf1
https://hg.mozilla.org/mozilla-central/rev/90483db905ac
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
(In reply to Julian Descottes [:jdescottes][:julian] from comment #11)
> Andrew: since bootstrapped addons are removed after 64, will they be
> uninstalled automatically from user profiles or is this something we should
> take care of ourselves?

We hadn't actually discussed this, but without us doing anything more, they should just move to the "Legacy/Unsupported" pane in about:addons.  So, if you've created a version of ADB Helper with a new ID, you should probably remove the old version (you can do this by serving and update to the old version that removes itself...)
Flags: needinfo?(aswan)
runtimePanel_noadbextension = Install ADB Extension
addons_adb_label2 = ADB Extension Add-on

Is "ADB Extension" the name of the add-on, or something else? Because, when I installed it, it shows up as "ADB binary provider" in about:addons.

If it's not part of the name, "Extension Add-on" is pleonastic.

This obviously affects localization, because only in one case it should be translated.
Flags: needinfo?(jdescottes)
It is my understanding that ADB Extension is the name of the addon (at least the repository is named https://github.com/mozilla/devtools-adb-extension). Although I agree "ADB Extension Add-on" still sounds bad. We could not localize this and simply use the addon's name. This is only displayed in a pretty obscure screen of WebIDE.
Flags: needinfo?(jdescottes) → needinfo?(francesco.lodolo)
That doesn't solve the question for the first string, and we already have translations all over the place.
https://transvision.mozfr.org/string/?entity=devtools/client/webide.dtd:runtimePanel_noadbextension&repo=gecko_strings

Most seems to assume "extension" is generic, not part of the name. One possible solution could be to put a placeholder
runtimePanel_noadbextension2 = Install %S

And hard-code this one
addons_adb_label2 = ADB Extension Add-on

At this point you'd need a new ID to change the first string.
Flags: needinfo?(francesco.lodolo)
Depends on: 1492049
Duplicate of this bug: 1482010
Blocks: 1492374
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.