Library window is missing dropmarker arrows

VERIFIED FIXED in Firefox 64

Status

()

defect
P1
normal
VERIFIED FIXED
11 months ago
11 months ago

People

(Reporter: ntim, Assigned: dao)

Tracking

({regression})

unspecified
mozilla64
Desktop
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox62 unaffected, firefox63 unaffected, firefox64 verified)

Details

Attachments

(3 attachments)

Posted image image.png
Dão, could this be related to bug 1487765 ?
Flags: needinfo?(dao+bmo)
Could be that, or bug 1470872.
Flags: needinfo?(dao+bmo)
Hmm, it's not clear to me how exactly this is failing. The dropmkarker's -moz-appearance, list-style-image, and display all seem to compute to the expected values, but somehow the image isn't rendered.
Keywords: regression
Priority: -- → P1
Brindusa, is there someone who can help us find a regression range here?
Flags: needinfo?(brindusa.tot)
I have performed a mozregression on this issue and these are my results:
16:21.67 INFO: No more inbound revisions, bisection finished.
16:21.67 INFO: Last good revision: 906330f7adc8cf71d9a39c1ff0fdd592ae7a9d28
16:21.67 INFO: First bad revision: 598ede9c5a5de8fcf23754e07a7c8079273013f4
16:21.67 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=906330f7adc8cf71d9a39c1ff0fdd592ae7a9d28&tochange=598ede9c5a5de8fcf23754e07a7c8079273013f4
Flags: needinfo?(brindusa.tot)
OS: Unspecified → Mac OS X
Hardware: Unspecified → Desktop
(In reply to Bodea Daniel [:danibodea] from comment #5)
> I have performed a mozregression on this issue and these are my results:

Thanks.
Assignee: nobody → dao+bmo
Blocks: 1487765
Status: NEW → ASSIGNED
I just noticed this bug, and was curious, so I had a quick play. Adding "-moz-image-region: auto" onto all the xul:dropmarker elements shows the dropmarkers again.

It looks like there's image region setting for the main icons on the buttons themselves, but that is scoped to the whole button, rather than just the xul:image on the button:

https://searchfox.org/mozilla-central/source/browser/themes/osx/places/organizer.css#144-157
(In reply to Mark Banner (:standard8) from comment #7)
> I just noticed this bug, and was curious, so I had a quick play. Adding
> "-moz-image-region: auto" onto all the xul:dropmarker elements shows the
> dropmarkers again.
> 
> It looks like there's image region setting for the main icons on the buttons
> themselves, but that is scoped to the whole button, rather than just the
> xul:image on the button:
> 
> https://searchfox.org/mozilla-central/source/browser/themes/osx/places/
> organizer.css#144-157

This makes sense as -moz-image-region is inherited. So we should re-add -moz-image-region: auto to dropmarker.css.
Component: Theme → Themes
Product: Firefox → Toolkit
Comment on attachment 9013553 [details]
Bug 1491400 - Cut off inheritance for dropmarkers within other widgets where -moz-image-region might be set for the primary icon. r?standard8

Mark Banner (:standard8) has approved the revision.
Attachment #9013553 - Flags: review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/19165a491295
Cut off inheritance for dropmarkers within other widgets where -moz-image-region might be set for the primary icon. r=Standard8
https://hg.mozilla.org/mozilla-central/rev/19165a491295
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
This issue has been fixed in Nightly v64.0a1 from 2018-10-03.
The issue is now verified. Thank you.
Status: RESOLVED → VERIFIED
Depends on: 1496491
No longer depends on: 1496491
You need to log in before you can comment on or make changes to this bug.