Closed Bug 1493057 Opened 3 years ago Closed 3 years ago

Make sure test_ext_privacy.js doesn't depend on the default value of the network.cookie.cookieBehavior preference

Categories

(WebExtensions :: General, defect)

defect
Not set
normal

Tracking

(firefox64 fixed)

RESOLVED FIXED
mozilla64
Tracking Status
firefox64 --- fixed

People

(Reporter: ehsan.akhgari, Assigned: ehsan.akhgari)

References

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

No description provided.
I know that this is doing part of what bug 1487297 was doing, but I need this to be able to enable the third-party cookie blocking feature on Nightly (in order to appease test_ext_privacy.js.
Blocks: 1492563
See Also: → 1487297
Comment on attachment 9010834 [details]
Bug 1493057 - Make sure test_ext_privacy.js doesn't depend on the default value of the network.cookie.cookieBehavior preference

Luca Greco [:rpl] has approved the revision.
Attachment #9010834 - Flags: review+
Pushed by eakhgari@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a99305d2fcb
Make sure test_ext_privacy.js doesn't depend on the default value of the network.cookie.cookieBehavior preference r=rpl
https://hg.mozilla.org/mozilla-central/rev/9a99305d2fcb
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Flags: qe-verify-
This is a change in the public-facing API and needs to be documented at:
- https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/privacy/websites#Properties

Also the fact that this change is Firefox-only needs to be reflected in the browser compatibility tables at
- https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/privacy/websites#Browser_compatibility
which is derived from this source:
- https://github.com/mdn/browser-compat-data/blob/b0dc0d3e530ab21e474608a062c28b290a6356c8/webextensions/api/privacy.json

Is this API final (considering bug 1487297)? If yes, please add the dev-doc-needed keyword so that the documentation gets updated.
Flags: needinfo?(ehsan)
You're right, my bad.
Flags: needinfo?(ehsan)
Keywords: dev-doc-needed
Duplicate of this bug: 1487297
Note to documentation team:

I have added a note to the 64 rel notes to cover this:
https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/64#Changes_for_add-on_developers

And added the new value to the privacy.websites page:
https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/privacy/websites

But the other tasks still need doing. Feel free to update my notes if I've got this wrong.

Was this for desktop Firefox only, i.e. not supported on Android?

Flags: needinfo?(rob)

The compat-data doesn't break down cookieConfig to provide information on its properties and therefore it doesn't provide any information about the values that behavior can take. The reject_trackers value is documented on privacy.websites, although there is no mention of the browser version it was introduced in, this would seem to be the extent to which we can document this feature.

The API is implemented in toolkit/, without any conditions, and the unit test from this bug is not skipped on Android. Therefore the extension API is available to Android.

The default value for the underlying preference was changed by the following bugs:

Bug 1492563 changed the default for cookieBehavior in Nightly on desktop.
Bug 1525727 changed the default for cookieBehavior on desktop for any desktop build.
Bug 1561385 changed the default for cookieBehavior on Android (also on Fennec because the patch was uplifted to the ESR68 branch).

I.e. on all currently supported release versions of Firefox, the default behavior is to deny tracking cookies.

(In reply to Richard Bloor from comment #11)

The compat-data doesn't break down cookieConfig to provide information on its properties and therefore it doesn't provide any information about the values that behavior can take. The reject_trackers value is documented on privacy.websites, although there is no mention of the browser version it was introduced in, this would seem to be the extent to which we can document this feature.

You could add a "notes" entry to the cookieConfig entry in BCD to document the updated API.

Flags: needinfo?(rob)

Docs work is complete; see https://github.com/mdn/sprints/issues/2141 for a description of what we did. Please, can we have a review?

I see that the PR has been merged, but the note does still not show up on MDN at https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/privacy/websites#Browser_compatibility

The release of BCD data usually happens on Thursdays (US time), and the deployment is usually later on the same day. This change should be included in this week's release/deployment. But, if it's not showing up by Friday, you need to do a shift-refresh while logged in.

You need to log in before you can comment on or make changes to this bug.