Closed Bug 1493140 Opened 1 year ago Closed 1 year ago

URL bar layout broken on RTL locales when the "Recommendation" label appears

Categories

(Firefox :: Address Bar, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1485725
Iteration:
65.1 - Nov 2

People

(Reporter: itiel_yn8, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: rtl, Whiteboard: [fxsearch])

Attachments

(1 file)

Attached image Recommendation label
See screenshot.

A few things to note:
1. Fade-out effect shouldn't be there
2. The Recommendation label is overlapping the Page Actions button (and probably also the separator?)
3. The add-on icon is missing
4. The "Recommendation" text should be on the left, the add-on icon on the right
Sorry for my ignorance, what is the recommendation label? Off-hand it looks like some code is not taking into account the urlbar structure.
Drew, do you know anything about this label?
Flags: needinfo?(adw)
Not sure what's the meta bug for this thing, but see bug 1492454. There's a GIF there that shows what it does.
Ah, it's add-on recommendations in the urlbar, looks like they confuse our overflow code in rtl mode.
We should really stop considering the urlbar input as a white canvas where everyone puts their stuff, there can be better hook points (action buttons, arrow panels, info button).

Tim, how do we track this bug properly for CFR? it's basically breaking the urlbar in RTL mode.
Flags: needinfo?(tspurway)
Priority: -- → P1
Whiteboard: [fxsearch]
Flags: needinfo?(adw)
Blocks: 1491379
Blocks: 1471328
Flags: needinfo?(tspurway)
See Also: → 1485725
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1485725
because we now have l10n targeting in 64, and all CFR recipes target en-US, this bug won't happen in 64.  moving to 65
Iteration: --- → 65.1 (Nov 2)
Priority: P1 → P2
You need to log in before you can comment on or make changes to this bug.