zoom issue on google maps on touch screen device

RESOLVED DUPLICATE of bug 1521082

Status

()

defect
P2
normal
RESOLVED DUPLICATE of bug 1521082
10 months ago
5 months ago

People

(Reporter: motfis, Unassigned)

Tracking

(Blocks 2 bugs)

64 Branch
Desktop
Windows 8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
Build ID: 20180921220134
Firefox for Android

Steps to reproduce:

open maps.google.com
pinch to zoom out/zoom in

nb : this issue appears on FF after v.59. On FF v.59 and before, the pinch to zoom in/out worked properly. My windows is 8.1 pro.


Actual results:

the map always goes to maximum zoom, and cannot keep the zoom state

video demonstration : https://www.dropbox.com/s/fz62724cfzyabt8/20180716_090016.mp4?dl=0


Expected results:

Firefox should keep the current zoom state, and the pinch to zoom in/out should work like normally.
OS: Unspecified → Windows 8.1
Hardware: Unspecified → Desktop
nb: I am sorry, the problem is not for FF android. It is for Windows.
Component: Untriaged → Panning and Zooming
Product: Firefox → Core
I can reproduce this, it's a pretty bad experience. It seems to be a problem with our pointer events implementation, since turning dom.w3c_pointer_events.enabled to false in about:config fixes the problem. The maps site listens for both pointer events and touch events, and if pointer events are disabled it will presumably do the right thing with the touch events.
Status: UNCONFIRMED → NEW
Component: Panning and Zooming → DOM: Events
Ever confirmed: true
Priority: -- → P2
Olli said it's probably something different in Chrome's/our interpretation of the Pointer Events spec.
Flags: needinfo?(bugs)
Duplicate of this bug: 1500564
any update about this bug..?
Blocks: 1521721
See Also: → 1521082
Depends on: 1521082
See Also: 1521082

I don't see map always goes to maximum zoom after bug 1521082. Hi Reporter, could you try latest nightly? Thank you.

Flags: needinfo?(bugs) → needinfo?(motfis)
Duplicate of this bug: 1508328

This issue also occurs on a Surface Pro 2 device (not ARM64) with Windows 10 Pro.

I am going to mark this bug as a duplicated of bug 1521082 given that we don't see this issue after it. We still have other issue for google map, but at least it won't always go to maximum zoom. Please feel free to file a separate bug if you experience any other issues. Thanks.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1521082

(In reply to Edgar Chen [:edgar] from comment #9)

I am going to mark this bug as a duplicated of bug 1521082 given that we don't see this issue after it. We still have other issue for google map, but at least it won't always go to maximum zoom. Please feel free to file a separate bug if you experience any other issues. Thanks.

*** This bug has been ma;rked as a duplicate of bug 1521082 ***

Hi Edgar, just tried a bit the latest nightly build (v.67). It seems the problem is fixed in this version. Thanks & looking forward for the official release.
nb: what other issue?

Flags: needinfo?(motfis)

(In reply to motfis from comment #10)

nb: what other issue?

There is a meta bug https://bugzilla.mozilla.org/show_bug.cgi?id=1521721 for issues on google map.

You need to log in before you can comment on or make changes to this bug.