Closed Bug 1494388 Opened Last year Closed 10 months ago

Remaining mochitest and reftest failures in TestRunnerActivity on x86 emulator

Categories

(GeckoView :: General, defect, P1)

Unspecified
Android
defect

Tracking

(geckoview62 wontfix, firefox-esr60 wontfix, firefox63 wontfix, firefox64 wontfix, firefox65 wontfix, firefox66 wontfix, firefox67 affected)

RESOLVED DUPLICATE of bug 1460411
Tracking Status
geckoview62 --- wontfix
firefox-esr60 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- affected

People

(Reporter: gbrown, Assigned: gbrown)

References

(Blocks 1 open bug)

Details

https://treeherder.mozilla.org/#/jobs?repo=try&tier=1%2C2%2C3&revision=46fc0ef6ed4c7ab1e83ae806b3e50b8e2501c51d

demonstrates that there are still several persistent test failures in mochitest-plain and reftest-plain suites on Android 7.0 x86 opt (running in TestRunnerActivity on the x86 emulator on packet.net).

It would be super-awesome if these could be investigated and fixed or disabled.
Flags: needinfo?(snorp)
Flags: needinfo?(nchen)
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
I think Jim's looking at some of these failures, but I'll try to look soon as well.
Flags: needinfo?(snorp)
QA Contact: nchen
Assignee: nchen → nobody
Status: ASSIGNED → NEW
Jim said he is looking into these x86 test failures.

For comparison, gbrown ran these tests in an x86-64 emulator (in bug 1498298). If we can get the x86-64 emulators running, we might not bother testing with the 32-bit x86 emulator.
Assignee: nobody → nchen
OS: Unspecified → Android
See Also: → 1498298
64=wontfix because this issue doesn't block Focus 8.0 from using GV 64.
Assignee: nchen → nobody
QA Contact: nchen
Product: Firefox for Android → GeckoView

Will this bug include enabling the mochitest-mda (dom/media) tests for x86_64? We currently run the "mda" tests on the Pixel 2 opt and debug and the Android 4.3 ARM emulator, but not the Android x86 or x86_64 emulators.

(In reply to Chris Peterson [:cpeterson] from comment #4)

Will this bug include enabling the mochitest-mda (dom/media) tests for x86_64? We currently run the "mda" tests on the Pixel 2 opt and debug and the Android 4.3 ARM emulator, but not the Android x86 or x86_64 emulators.

I filed mda bug 1525469 just in case.

Depends on: 1525469

We still have mochitest and reftest failures to investigate, but all that work seems to be happening in bug 1460411 and bug 1501582.

Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: geckoview_mochitest
You need to log in before you can comment on or make changes to this bug.