Closed Bug 1495238 (SQLIte3.25.3) Opened Last year Closed Last year

Upgrade to SQLite 3.25.3

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla65
Tracking Status
firefox63 --- unaffected
firefox64 --- wontfix
firefox65 --- fixed

People

(Reporter: ionnv, Assigned: RyanVM)

References

Details

Attachments

(1 file)

https://www.sqlite.org/news.html

https://www.sqlite.org/releaselog/3_25_2.html

"SQLite version 3.25.2 is another patch against 3.25.0 that fixes still more problems associated with the new window function feature and the ALTER TABLE enhancements. Of particular note is the new PRAGMA legacy_alter_table=ON command, which causes the ALTER TABLE RENAME command to behave in the same goofy way that it did before the enhancements found in version 3.25.0 → references to renamed tables that are inside the bodies of triggers and views are not updated. The legacy behavior is arguably a bug, but some programs depend on the older buggy behavior. The 3.25.2 release also contains a fix to window function processing for VIEWs. There also a slew of other minor fixes that affect obscure compile-time options. See the Fossil Timeline for details."
Depends on: SQLIte3.25.1
Marco, any urgency for this on your end?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mak77)
FWIW, there's already been a few more commits to upstream branch-3.25, so I wouldn't be shocked if there's going to be a 3.25.3 release coming in the near-ish future.
No urgency, we don't use the new features yet. And I agree with comment 2 that looks like there will be another dot version, let's wait a bit for now.
Flags: needinfo?(mak77)
2018-11-05 - Release 3.25.3
SQLite version 3.25.3 is a third patch against 3.25.0 that fixes various problems that have come to light and which seem serious enough to justify a patch.

Want to take it, Marco?
Alias: SQLIte3.25.2 → SQLIte3.25.3
Flags: needinfo?(mak77)
Summary: Upgrade to SQLite 3.25.2 → Upgrade to SQLite 3.25.3
yep, this one's good, even if they are very unlikely to affect us. Though someone may start using window functions.
Flags: needinfo?(mak77)
Assignee: nobody → ryanvm
I'm thinking I'll try to uplift this to Beta as well. Though maybe without the version bump in old-configure.in?
(In reply to Ryan VanderMeulen [:RyanVM] from comment #6)
> I'm thinking I'll try to uplift this to Beta as well. Though maybe without
> the version bump in old-configure.in?

I don't think it's necessary, the fixes are unlikely to affect us, as I said. Just good to have for fixes to new features.
OK, fine by me.
https://hg.mozilla.org/mozilla-central/rev/3ac8b35289ed
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
Blocks: SQLIte3.26.0
You need to log in before you can comment on or make changes to this bug.