Status

()

task
P3
normal
RESOLVED FIXED
9 months ago
12 days ago

People

(Reporter: surkov, Assigned: surkov)

Tracking

(Blocks 2 bugs)

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

9 months ago
No description provided.
Assignee

Comment 1

9 months ago
Posted patch patch (obsolete) — Splinter Review
based on bug 1495357
Attachment #9013491 - Flags: review?(paolo.mozmail)
Assignee

Updated

9 months ago
Priority: -- → P3

Comment 2

9 months ago
Comment on attachment 9013491 [details] [diff] [review]
patch

Review of attachment 9013491 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/content/widgets/wizard.js
@@ +26,5 @@
> +    this.parentNode._accessMethod = "random";
> +    return val;
> +  }
> +}
> +customElements.define("wizardpage", MozWizardHeader);

This should be MozWizardPage. Did this patch pass manual or automated testing?

If none of the properties are actually used anywhere, or can be replaced by direct calls, we might as well remove the binding without making it a Custom Element.

This should also be based on mozilla-central, without the other patches for wizard conversions, like the MozWizardButtons that I see this is based on.
Attachment #9013491 - Flags: review?(paolo.mozmail)
Blocks: 1495621
Assignee

Comment 3

9 months ago
Posted patch patchSplinter Review
this one is rebased relative trunk
Attachment #9013491 - Attachment is obsolete: true
Attachment #9014256 - Flags: review?(paolo.mozmail)

Comment 4

9 months ago
Comment on attachment 9014256 [details] [diff] [review]
patch

Looks good to me.
Attachment #9014256 - Flags: review?(paolo.mozmail) → review+
Let's hold off on landing this until we figure out what's going on with Bug 1495946, since it's related to wizard/wizardpage.
Depends on: 1495946
No longer depends on: 1495946
See Also: → 1495946

Comment 6

3 months ago
Pushed by surkov.alexander@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/62fac4388d24
Conver wizardpage binding to Custom Elements, r=paolo

Comment 7

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

This seems to have caused bug 1533396

Blocks: 1533396

Updated

3 months ago
Depends on: 1533660

Updated

3 months ago
Duplicate of this bug: 1533674

Could this change affect other dialogs besides Profile manager? Should we test anything in particular to make sure nothing else was damaged?

Flags: needinfo?(surkov.alexander)
Assignee

Comment 11

3 months ago

(In reply to Anca Soncutean [:Anca], Desktop Release QA from comment #10)

Could this change affect other dialogs besides Profile manager? Should we test anything in particular to make sure nothing else was damaged?

I'm aware of two wizards in Firefox: ProfileManager and Import Wizard (Library -> Import Data ...). It's worth to check the second one for sure.

Dave, are there any other wizards?

Flags: needinfo?(surkov.alexander) → needinfo?(dtownsend)

There is this: https://searchfox.org/mozilla-central/source/toolkit/mozapps/update/content/updates.xul

Apparently it is only ever used if you're extremely out of date or we fail to elevate on OSX. If you need to trigger this then mhowell might be able to help.

Flags: needinfo?(dtownsend)

Updated

12 days ago
Type: enhancement → task
You need to log in before you can comment on or make changes to this bug.