Closed Bug 1533396 Opened 2 years ago Closed 2 years ago

Can't create a new profile with the Profile Manager

Categories

(Toolkit :: Startup and Profile System, defect)

67 Branch
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 --- verified

People

(Reporter: Ovidiu, Assigned: surkov)

References

Details

(Keywords: regression)

Attachments

(1 file)

Affected versions

  • Nightly 67.0a1

Affected platforms

  • Mac 10.14, Ubuntu 16.04, Windows 10

Steps to reproduce

  1. Try to create a new profile using the Profile Manager.

Expected result

  • You can create a new profile

Actual result

  • You are not able to create a new profile, you are prompted with a blank page in the Profile Manager.
    If you try a second time to create a new profile, it works.

Additional notes

  • This is a regression, with the Nightly build from 2019-03-06 this issue can't be reproduced.
Depends on: 1495622

Backing out the patch in bug 1495622 fixes this.

Flags: needinfo?(surkov.alexander)

It looks like clicking next on the first page of the wizard sends us to page -1.

[Tracking Requested - why for this release]:

Since this is a regression from a change to a core UI component seems likely there is other bustage around that we haven't spotted yet. Probably should fix or back-out before uplift.

(In reply to alexander :surkov (:asurkov) from comment #4)

Created attachment 9049248 [details]
Bug 1533396 - Can't create a new profile with the Profile Manager, r=mossop

wizzard attempts to set page index before wizard page attached callback is called.

Flags: needinfo?(surkov.alexander)
Assignee: nobody → surkov.alexander
Pushed by asurkov@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4256ff8a181c
Can't create a new profile with the Profile Manager, r=mossop
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1533660
Duplicate of this bug: 1533674

I verified this on Mac OS X 10.14, Ubuntu 16.04 and Windows 10 and I can confirm the fix.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.