JavaScript error: resource://gre/modules/ActorManagerChild.jsm, line 72: NS_ERROR_FILE_NOT_FOUND:

RESOLVED FIXED in Thunderbird 65.0

Status

defect
RESOLVED FIXED
10 months ago
9 months ago

People

(Reporter: jorgk, Assigned: jorgk)

Tracking

Trunk
Thunderbird 65.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird63 wontfix, thunderbird64 fixed, thunderbird65 fixed)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1485649 +++

https://taskcluster-artifacts.net/AGyzGCxlT_uSUSpm3G4j0g/0/public/logs/live_backing.log

shows this error
JavaScript error: resource://gre/modules/ActorManagerChild.jsm, line 72: NS_ERROR_FILE_NOT_FOUND:

542 times.

Interested, Magnus?
Flags: needinfo?(mkmelin+mozilla)
This is because the modules provided by toolkit are not packaged.

@RESPATH@/actors/*
OK, let's see what that does. Thanks Alta88!
Assignee: nobody → jorgk
Flags: needinfo?(mkmelin+mozilla)
Comment on attachment 9020084 [details] [diff] [review]
1495898-actors.patch

I guess that's broken on the beta, too.
Attachment #9020084 - Flags: approval-comm-beta+
Target Milestone: --- → Thunderbird 65.0
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/3a32487f3a23
add @RESPATH@/actors/* to package manifest (analysis by Alta88). rs=bustage-fix
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Yes,  Broken in 63.0b1
Thanks. I'll check the fix on trunk and then it goes to TB 64 beta.
Total success, error gone - \o/
Weren't there a lot of webextension tests that were turned off?  They should be turned on if we're going to be serious about implementing it properly..
They've all been turned on again here: https://hg.mozilla.org/mozilla-central/rev/163742dd3235
Duplicate of this bug: 1502219
Test management has been really excellent, I just want to point out that web extension tests also need to be reviewed and some that seem to potentially apply to Tb have been turned off:

+skip-if = appname == "thunderbird" || os == "android"
 [test_ext_cookieBehaviors.js]
..
+fail-if = appname == "thunderbird"
 skip-if = os == "android"
 [test_ext_downloads_misc.js]
..
+fail-if = appname == "thunderbird"
 [test_ext_extension.js]
..
+skip-if = appname == "thunderbird"
 [test_ext_onmessage_removelistener.js]
..
+skip-if = appname == "thunderbird"
 [test_ext_webRequest_startup.js]
..
+skip-if = appname == "thunderbird"
 [test_ext_xhr_capabilities.js]

Some Fx web extensions should Just Work in Tb at this point. For example, script injection doesn't seem to work and it may be because the messageManager object attached to messagepane <browser> doesn't have a processMessageManager handler, from what I've debugged so far in uBlock, which finally semi works for http urls given this patch.

(I know it's separate bugs, I'm just sayin..)
(In reply to alta88 from comment #12)
> (I know it's separate bugs, I'm just sayin..)
Thanks for you help in this bug, especially since it also fixed an urgent print preview problem (see bug 1502219).

I'd appreciate it very much if you could file a new bug for the WE stuff and CC me and geoff@thunderbird.net.
You need to log in before you can comment on or make changes to this bug.