When customizing browser, going from 'Normal' or 'Touch' to 'Compact' causes close window text ('x') to go under button.

RESOLVED FIXED in Firefox 66

Status

()

defect
RESOLVED FIXED
7 months ago
3 months ago

People

(Reporter: sparky, Assigned: stransky)

Tracking

(Blocks 1 bug)

62 Branch
mozilla66
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

(Whiteboard: [qa-66b-p2])

Attachments

(3 attachments)

(Reporter)

Description

7 months ago
I've attached a screenshot showing (in the top right corner) how the minimize, full size, and close text for the buttons goes down under the actual buttons.

I can always reproduce this by doing the following:
1. Go to 'Customize...'
2. Disable the title bar.
3. Start on 'Normal' or 'Touch' mode at the bottom of the screen, in the 'Density' drop-down menu.
4. Change to 'Compact' mode and watch the text for the buttons move away.

I found that it's also possible for this to happen when going from 'Compact' to 'Normal' mode, though it doesn't always happen.

This is happening on a machine running Ubuntu 18.04.
(Reporter)

Comment 1

7 months ago
What it looks like on 'Normal' density mode when the bug is not present.
(Reporter)

Comment 2

7 months ago
Furthermore, when this bug occurs and I hover over the tabs and address bar area, the text for those buttons (-, square, X) will move themselves to the correct area.

Comment 3

7 months ago
Linux titlebar decoration issues -> off to Core:: Widget: GTK. :stransky, are you the right person to ask about these? If not could you please forward the ni? Thank you!
Blocks: gtktitlebar
Component: Toolbars and Customization → Widget: Gtk
Flags: needinfo?(stransky)
Product: Firefox → Core
(Assignee)

Comment 4

7 months ago
Sure. Greg, do you have dragspace enabled? Is that fixed when main window is resized? If so it's a dupe of Bug 1447775.
Flags: needinfo?(stransky)
(Reporter)

Comment 5

7 months ago
Drag space is not enabled, and playing with it's setting does not fix the bug or affect it in any way. And this bug only happens when the main window is at full-size, I haven't been able to reproduce it at smaller sizes. Plus, anytime I move the cursor towards the 'x' button, the text repositions itself over top of the button (or it fixes itself). 

I don't think that this is the same bug because I haven't seen the actual button move down vertically. I've been able to reproduce that bug you mention though by starting with a small main window with drag space enabled, and then maximizing the window, making the buttons move (down) away from the vertical center. Once drag space is disabled, the buttons return to their correct positions.

I did some testing and found that the Ubuntu 18.04 display settings need to be set to 200% scale (default), at 100% there's no bug - unless Firefox was opened before changing the display settings, then the bug will persist.
(Reporter)

Comment 6

7 months ago
The bug I'm seeing is similar to this one which is marked as a duplicate of Bug 1447775: Bug 1460958

But in my case, resizing has no effect on the bug, only mouse hovering. It's fine if you mark this as a duplicate, I'll test with the patch that will be made for that bug on this one.
(Assignee)

Updated

4 months ago
Assignee: nobody → stransky
(Assignee)

Updated

3 months ago
Keywords: checkin-needed

Comment 9

3 months ago

Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a22edb5c335
[Linux/CSD] Position headerbar button icons according to the actual button, r=jhorak

Keywords: checkin-needed

Comment 10

3 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

Updated

3 months ago
Depends on: 1519606
Whiteboard: [qa-66b-p2]
You need to log in before you can comment on or make changes to this bug.