Closed Bug 1497523 Opened Last year Closed 11 months ago

Forms and Autofill is not focused by automatic scrolling when opened from the autocomplete footer

Categories

(Toolkit :: Form Autofill, defect, P2)

Unspecified
All
defect

Tracking

()

VERIFIED FIXED
mozilla64
Tracking Status
firefox-esr60 --- unaffected
firefox62 --- unaffected
firefox63 --- unaffected
firefox64 --- verified

People

(Reporter: david.olah, Assigned: MattN)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]: 
Nightly 64.0a1 (2018-10-09)

[Affected platforms]:
Platforms: Windows 10, Mac OS X, Ubuntu 16.04.

[Preconditions]:

Modify the following prefs via about:config:

- extensions.formautofill.available: on
- extensions.formautofill.creditCards.available: true

Make sure you have 1 or more credit cards saved.

[Steps to reproduce]:
1. Go to: https://luke-chang.github.io/autofill-demo/basic.html
2. Double click name or address field from the page
3. Click on "more options" button (preferences on Mac)

[Expected result]:
- User is redirected to about:preferences#privacy and Forms & Autofill is focused by autoscrolling

[Actual result]:
- User is redirected to about:preferences#privacy and the focus remains in top of the page (Forsm & Autofill is not focused by autoscrolling)

[Note]:
On 62 and 63, the Forms & Autofill section was olmost on the top of the page and no scroll was needed.
I guess this is kinda a regression from moving the content blocking section up top. IIRC the problem before was that there wasn't a link to highlight both autofill sections. Since bug 1470184 there is now.
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Depends on: 1470184
Keywords: regression
Priority: -- → P2
Summary: Forms and Autofill is not focused bu automatic scrolling → Forms and Autofill is not focused by automatic scrolling when opened from the autocomplete footer
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/e0aa704cdd63
Link to '#privacy-form-autofill' prefs instead of '#privacy' from autofill. r=jaws
https://hg.mozilla.org/mozilla-central/rev/e0aa704cdd63
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Flags: qe-verify+
Verified as fixed with 64.0a1 (2018-10-17) from taskcluster on Windows 10x64, MacOS 10.14 and Ubuntu 16.04.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.