Closed Bug 1497572 Opened Last year Closed 10 months ago

Improve custom deployment experience

Categories

(Webtools :: Pontoon, enhancement, P4)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mathjazz, Assigned: vishalcr7)

References

Details

Attachments

(1 file)

If a user deploys Pontoon with the "Deploy to Heroku" button, links to /teams and /projects (exposed in the main navigation bar) 404, because we don't create any non-system projects by default.

Developers experience the same behaviour in their local setups.

Instead of 404ing, we should show "empty" Teams and Projects dashboards with a link to "Set up your first project". Once the first (non-system) project is set up, /teams and /projects links will work.

We should also fix the broken link in the CTA ("Start Localizing Now") by passing Locale.objects.visible() to get_project_locale_from_request().

Later on (as part of a different bug) we should also change the homepage content to something more generic and add the ability to customize it for each instance (and do so for pontoon.mozilla.org).
Duplicate of this bug: 1520802
Assignee: nobody → vishaliitr7
Status: NEW → ASSIGNED
Commit pushed to master at https://github.com/mozilla/pontoon

https://github.com/mozilla/pontoon/commit/a806a54a7f2c8cabeeecaaefa0fbef3c411cb291
Fix bug 1497572: Improve custom deployment experience  (#1181)

After initial Pontoon set up, the /teams and /projects page 404. With
this patch we display a quick notice that no projects have been set
up yet with a link to set them up.

Relatedly, the "Start Localizing Now" CTA link on the homepage is broken
and this patch fixes it.
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
See Also: → 1522520
You need to log in before you can comment on or make changes to this bug.