Closed Bug 14990 Opened 21 years ago Closed 20 years ago

[PP] Can't double-click on Mac OS

Categories

(Core :: DOM: Selection, defect, P3)

PowerPC
Mac System 8.5
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: elig, Assigned: Brade)

References

Details

* TITLE/SUMMARY
[PP] Can't double-click on Mac OS or Unix

* STEPS TO REPRODUCE
0) Launch Apprunner
1) View Demo #0 (or any other page)
2) Attempt to double-click on any word, either within the browser or within the
editor.

* RESULT
 - What happened

No selection takes place; if using the editor, the editing caret is instead
placed. Triple-clicking, however, works on Mac OS.

 - What was expected

Behavior equivalent to Win32 builds.

* REGRESSION

 - Occurs On
        Mac OS Apprunner (1999092708 optimized build)
        Linux Apprunner (1999092708 optimized build)

 - Doesn't Occur On
        Win32 Apprunner (1999092708 optimized build [NT 4, Service Pack 3])




* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP3.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
Is this because of the removal of the double-click message?
no, it's not because it has been removed on Mac and Unix (it hasn't yet).
However, it could be because it *hasn't* been removed yet (it was removed on
Windows a while ago by joki).

Any ideas Mike?
Blocks: 14018
Please note that there may be separate issues on Mac OS and Linux.

In yesterday's Linux build, triple-clicks also don't work. However, triple-clicks
work correctly on yesterday's Mac OS build.
Hmm...triple-clicking is also broken on Win32 (today's build), but works fine on
Mac.

Will open up a separate bug report to track that problem.
Broke the triple-click issue into 15095
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
resolving as fixed since this works for me on Friday's build.  Eli--please
verify.
Status: RESOLVED → REOPENED
While it worked on 1999100708 Linux build, this issue still occurs on the
1999100708 (same day) Mac OS build.

Thus, re-opening.
Resolution: FIXED → ---
Summary: [PP] Can't double-click on Mac OS or Unix → [PP] Can't double-click on Mac OS
changing summary to remove "unix" since this isn't a problem at the moment
Status: REOPENED → ASSIGNED
I have a fix which has been code reviewed by sfraser@netscape.com.
Blocks: 9981
Status: ASSIGNED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → FIXED
fix checked in before tree closure today.
Status: RESOLVED → VERIFIED
Verified fixed in 1999101812 Mac OS build.

(Additional related issues still take place, but those are all documented as re-
opened duplicates of 9981.)
setting to an approximate milestone so it can be off of the no TFV list
Target Milestone: --- → M10
You need to log in before you can comment on or make changes to this bug.