Closed Bug 1499240 Opened Last year Closed Last year

TEST-UNEXPECTED-FAIL | [snip]subscribe/test-subscribe-news-filter.js | test-subscribe-news-filter.js::test_subscribe_newsgroup_filter

Categories

(Thunderbird :: General, defect)

defect
Not set

Tracking

(thunderbird64 fixed, thunderbird65 fixed)

RESOLVED FIXED
Thunderbird 65.0
Tracking Status
thunderbird64 --- fixed
thunderbird65 --- fixed

People

(Reporter: jorgk, Assigned: darktrojan)

References

Details

(Whiteboard: [Thunderbird-testfailure: Z Linux][Thunderbird-disabled-test])

Attachments

(3 files)

TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/subscribe/test-subscribe-news-filter.js | test-subscribe-news-filter.js::test_subscribe_newsgroup_filter

https://taskcluster-artifacts.net/c9HbMK-LStWco4_GjFzTXw/0/public/logs/live_backing.log

INFO -  SUMMARY-UNEXPECTED-FAIL | test-subscribe-news-filter.js | test-subscribe-news-filter.js::test_subscribe_newsgroup_filter
INFO -    EXCEPTION: test.subscribe.empty not in the list
INFO -      at: utils.js line 396
INFO -         TimeoutError utils.js:396 13
INFO -         waitFor utils.js:452 11
INFO -         filter_test_helper test-subscribe-news-filter.js:41 3
INFO -         callback test-subscribe-window-helper.js:46 5
INFO -         Runner.prototype.wrapper frame.js:579 7
INFO -         startTest test-window-helpers.js:327 11
INFO -         Subscribe mailCommands.js:347 3
INFO -         MsgSubscribe mailWindowOverlay.js:2108 5
INFO -         oncommand messenger.xul:1 1
INFO -         MozMillController.prototype.click controller.js:531 5
INFO -         wrapperFunc test-window-helpers.js:1165 32
INFO -         open_subscribe_window_from_context_menu test-subscribe-window-helper.js:49 3
INFO -         test_subscribe_newsgroup_filter test-subscribe-news-filter.js:31 3

M-C last good: 6e0139775220f26e08be6494978e64617f
M-C first bad: 4a230b07f0cbf48e87dcb4265ea2d00893
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6e0139775220f26e08be6494978e64617f&tochange=4a230b07f0cbf48e87dcb4265ea2d00893
Whiteboard: [Thunderbird-testfailure: Z Linux] → [Thunderbird-testfailure: Z Linux][Thunderbird-disabled-test]
Version: 60 → Trunk
Flags: needinfo?(acelists)
Summary: TEST-UNEXPECTED-FAIL | /builds/worker/workspace/build/tests/mozmill/subscribe/test-subscribe-news-filter.js | test-subscribe-news-filter.js::test_subscribe_newsgroup_filter → TEST-UNEXPECTED-FAIL | [snip]subscribe/test-subscribe-news-filter.js | test-subscribe-news-filter.js::test_subscribe_newsgroup_filter
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/10e11612c20d
Temporarily switch off failing test-subscribe-news-filter.js on Linux. rs=bustage-fix
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Note the fix of bug 1499286.
This looks like it has the same problem, although what's causing it, I don't know. Has somebody been playing around with CustomElements again?
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(acelists)
Attachment #9017461 - Flags: review?(jorgk)
The version of <textbox> in https://dxr.mozilla.org/comm-central/source/toolkit/content/widgets/textbox.xml handles and fires commands, the version at https://dxr.mozilla.org/comm-central/source/comm/common/bindings/textbox.xml does not. 
Why do we have a copy of it?
Comment on attachment 9017461 [details] [diff] [review]
1499240-subscribe-news-filter-1.diff

So the fix here like in bug 1499286 is:
-                       oncommand="Search();"/>
+                       oninput="Search();"/>
Most likely something like this will also fix bug 1499316. But why is this only necessary on Linux?

NI Richard for comment #5.
Flags: needinfo?(richard.marti)
Attachment #9017461 - Flags: review?(jorgk) → review?(acelists)
(In reply to :aceman from comment #5)
> The version of <textbox> in
> https://dxr.mozilla.org/comm-central/source/toolkit/content/widgets/textbox.
> xml handles and fires commands, the version at
> https://dxr.mozilla.org/comm-central/source/comm/common/bindings/textbox.xml
> does not. 
> Why do we have a copy of it?

Because of the removal of some bindings like spinbuttons, numberbox etc.
Why it doesn't handle and fire commands? I don't know.
Flags: needinfo?(richard.marti)
You made our copy of textbox.xml in bug 1453322, but it doesn't contain the command handling which was in the m-c version of textbox.xml at that time. So where did you copy it from? Or did you strip it? Also there were further changes in the m-c version of the textbox.xml since then, which we may need/want to port.
Or we could use the m-c textbox.xml again. Do we lose anything except the spinbuttons? Yeah I remember the awful long textboxes, where size (or what was the attribute for number of digits called) was ignored. Would that return too?
If I remember correctly it was a stripped version with only the removed bindings.
It does not look like anything that would extend the "textbox" binding in toolkit. It seems to replace it, the parts are very similar.
But now I see it only contains the "textbox" binding. The m-c file contains also "search-textbox" which extends "textbox" and this one isn't duplicated in c-c. This one implements some command handling.

The <textbox id="namefield"> is of type="search". That gets the binding of chrome://global/content/bindings/textbox.xml#search-textbox . I wonder which textbox implementation does this extend, the c-c or the m-c one?

Anyway, I still don't see what has changed yesterday to cause the change in behaviour and only on Linux.
Observing the test run and comparing to a month old run, I see these warnings are new in the console:
[28518, Main Thread] WARNING: NS_ENSURE_TRUE(browserChrome) failed: file mozilla/docshell/base/nsDocShell.cpp, line 12739
Chrome file doesn't exist: mozilla/obj-x86_64-pc-linux-gnu/dist/bin/chrome/toolkit/content/global/textbox.css

Interestingly, when operating the search box in the subscribe dialog (that fails in the test), manually it works just fine. With the 'oncommand'.
This updates textbox.xml to the state in m-c, except their last bug 1470910, which converts it to CustomElements.
Try run:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&selectedJob=205966612&revision=47e706d7c6d83cd4037bbc864634cd284cc1699d
Attachment #9017778 - Flags: review?(richard.marti)
Comment on attachment 9017778 [details] [diff] [review]
1499240.patch - udate textbox.xml

LGTM and I see no change in the Accessibility inspector. But the try is without enabling the disabled tests, true?

The searchbox in subscribe.xul doesn't use our binding but the toolkit one. So the test shouldn't be affected by your change, correct?
Attachment #9017778 - Flags: review?(richard.marti) → review+
Yes, this does not fix the test, it just syncs the textbox.xml a bit with the m-c version so that we have less differences to wonder about and so it does not reference non-existent interfaces like nsIDOMXULTextBoxElement.

Can you see why there is the error about chrome/toolkit/content/global/textbox.css ? Does that exist and can TB access it?
They removed the content/global/textbox.css in bug 1473927. We need to delete the line at https://searchfox.org/comm-central/source/mail/base/content/bindings.css#5 .
Keywords: leave-open
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/8d9aee111a9d
clean up textbox.xml according to toolkit version of the file. r=Paenglab
Depends on: 1501138
Keywords: leave-open
Target Milestone: --- → Thunderbird 65.0
Comment on attachment 9017461 [details] [diff] [review]
1499240-subscribe-news-filter-1.diff

Let's take this now until we have a better idea.
Attachment #9017461 - Flags: review?(acelists) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1f384411c0ac
Fix failing test by listening for input event instead of command event. r=jorgk
https://hg.mozilla.org/comm-central/rev/791655b49756
Backed out changeset 10e11612c20d to re-enable test. a=backout
Status: ASSIGNED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Attachment #9017461 - Flags: approval-comm-beta+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/f025f3714b77
Backed out changeset 1f384411c0ac to restore code to original state. a=backout
You need to log in before you can comment on or make changes to this bug.