Closed Bug 15001 Opened 21 years ago Closed 20 years ago

[DOGFOOD] Display problem when adding more than 3 recipients in AddressingWidget

Categories

(MailNews Core :: Composition, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 16709

People

(Reporter: laurel, Assigned: bugzilla)

References

Details

(Whiteboard: [PDT+])

Attachments

(1 file)

Using September 27th build on linux 6.0 and NT 4.0
(haven't yet tried mac)

After adding more than a couple addressee lines in a message compose window, the
addressing block display goes bananas -- refresh doesn't help.

1.  From messenger window, New Msg.
2.  In the message compose window, type a name on the first address line and hit
return.
    Repeat to add several addressee lines.
Result:  addressing block display goes weird and often runs into subject line.
Scrolling within the addressing block makes it worse -- often adding blank
address lines at top of block.  Can't tell what addresses have been entered.
QA Contact: lchiang → laurel
Same on mac.
Overall problems occur when adding lines which will exceed the current viewing
area of the address block. Scrolling makes the area worse.
Assignee: ducarroz → hangas
Status: NEW → ASSIGNED
Target Milestone: M11
Blocks: 11091
Assignee: hangas → ducarroz
Status: ASSIGNED → NEW
Sending to JF
Summary: Problems adding more than a few message compose address lines. → [DOGFOOD] Problems adding more than a few message compose address lines.
I'd like to recommend this for a Dogfood usage bug for review by PDT team. This
is a problem that seems to be easily encountered by folks.
Whiteboard: [PDT+]
Putting on [PDT+] radar.
Status: NEW → ASSIGNED
Blocks: 16841
Summary: [DOGFOOD] Problems adding more than a few message compose address lines. → [DOGFOOD] Display problem when adding more than 3 recipients in AddressingWidget
I am focusing this bug on the display/clipping problem of the addressing Widget. Therefore I have updated the
summary to reflect the real problem.
Assignee: ducarroz → trudelle
Status: ASSIGNED → NEW
Have just added a sample xul file that demonstrate the display/clipping problem. Open it into the browser and you
will see the problem right away. Reassign to trudelle.
Assignee: trudelle → hyatt
reassigning to hyatt for triage.  Possible workaround is to use a table rather
than a tree for this, is that an option for you?
Blocks: 16950
Assignee: hyatt → buster
reassigning to buster per hyatt, should be fixed by lightweight ender.
could somebody explain to me what I'm supposed to do with this bug?
Hyatt, what is the editor doing to cause display problems in mail compose?  I
see the problem, but I don't understand why you think the editor is doing
something wrong, or why "lightweight ender" (I don't really know what this
means, the term has been applied to lots of different things) will fix it.
Blocks: 12658
Blocks: 17432
Assignee: buster → trudelle
reassigning to Trudelle -- see buster's comment above.
Assignee: trudelle → ducarroz
Although this probably could be fixed in the toolkit, I suspect mail/news is
going to have to find a workaround where we remember the recipient data on our
own. Reassigning to ducarroz.
Ok, this is being worked on elsewhere. Marking a dup.

*** This bug has been marked as a duplicate of 16709 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Using builds 1999121309 on win98, and build 19991211308m12 mac and linux, this
is not fixed completely, but as stated regarding displaying of names this is
fixed.  However, if you scroll to get to the 4th line, then send, some of the
recipients  don't get messages (logging a separate bug for that).
No longer blocks: 16841
No longer blocks: 17432
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.