No gear menu in Recent Updates panel of new about:addons

VERIFIED FIXED in Firefox 64

Status

()

P2
minor
VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: yfdyh000, Assigned: mstriemer)

Tracking

64 Branch
mozilla65
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 verified, firefox65 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 months ago
STR:
1. View Recent Updates in new about:addons.
2. Try to check for updates for add-ons.


Actual results:
No "check for updates" menu for now. I had to go to the other panel to use it and other menus of the gear menu and then return.


Expected results:
Allow to check for updates.
(Assignee)

Comment 1

5 months ago
The gear was moved into the list view heading. Perhaps the list view heading should be part of the regular heading though.
Priority: -- → P2
(Assignee)

Updated

5 months ago
Assignee: nobody → mstriemer
(Assignee)

Comment 3

5 months ago
Posted video gear-everywhere.mov

Comment 4

5 months ago
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56f06760024b
Include gear on each page of about:addons r=jaws
(Assignee)

Comment 5

5 months ago
Comment on attachment 9018396 [details]
Bug 1500165 - Include gear on each page of about:addons r?jaws

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1488730

User impact if declined: The gear menu in about:addons is hidden on some views, like the recent and available updates views.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Moves markup for the gear menu out of list view, closer to where it was before.

String changes made/needed: None
Attachment #9018396 - Flags: approval-mozilla-beta?

Comment 6

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/56f06760024b
Status: NEW → RESOLVED
Last Resolved: 5 months ago
status-firefox65: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla65
status-firefox63: --- → unaffected
status-firefox-esr60: --- → unaffected
IMO this should have some verification if we're going to uplift.  If not from automated tests, then manual QA.
Flags: qe-verify+

Comment 8

5 months ago
I managed to reproduce the issue using version 64.0a1 (20181018123730). Check for updates is not available on the Recent Updates page.

I retested using 65.0a1 (20181105100136) on Windows 10 x64, macOS 10.13.6 and Ubuntu 16.04 x64 and the issue is fixed as the check for updates option is available on the Recent Updates page.
status-firefox65: fixed → verified
Flags: qe-verify+
Comment on attachment 9018396 [details]
Bug 1500165 - Include gear on each page of about:addons r?jaws

about:addons fix, approved for 64.0b8
Attachment #9018396 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
We encountered a conflict while trying to uplift:

warning: conflicts while merging toolkit/mozapps/extensions/content/extensions.xul! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue

@mstriemer can you please provide a patch for beta? Thank you.
Flags: needinfo?(mstriemer)
(Assignee)

Comment 11

4 months ago
Posted patch 1500165.patchSplinter Review
Flags: needinfo?(mstriemer)
(Assignee)

Comment 12

4 months ago
This patch should work on Beta.

Comment 13

4 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/bf39f03ec712
status-firefox64: affected → fixed

Comment 14

4 months ago
Verified as fixed using DevEdition 64.0b8 (20181108141956) on Windows 10 x64, macOS 10.13.6 and Ubuntu 16.04 x64. The check for updates option is available on the Recent Updates page.
status-firefox64: fixed → verified

Updated

4 months ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.