Closed Bug 1500441 Opened 2 years ago Closed 2 years ago

Make site-wide announcement dismissable

Categories

(bugzilla.mozilla.org :: User Interface, enhancement)

Production
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: kohei.yoshino, Assigned: dylan)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

It would be nice if the banner announcement can be dismissable.

Implementation: When the user dismissed it, cache the current announcement text in the local storage, and hide the same announcement next time they open a page. When a different announcement comes up, it should be displayed normally and again dismissable.
Assignee: kohei.yoshino → dylan
Attached file GitHub Pull Request
Duplicate of this bug: 1515811
Duplicate of this bug: 1515994
Duplicate of this bug: 1516148
Now that these are being used more frequently, and for a longer time, it'd be nice to see a higher priority on this.  Every bug I read is wasting 1" of screen real estate on "Frosty the Snowentity" and has been for a week..
I built an extension to hide this, temporarily.  Source is at https://github.com/djmitche/hide-bmo-announcements.  It's stupid-simple, and my first extension :)

Closing this; the code landed a while ago and will be on prod in several hours.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

(In reply to Dylan Hardison [:dylan] (he/him) from comment #7)

Closing this; the code landed a while ago and will be on prod in several hours.

Is this already on prod? Because the current announcement is still not dismissable.

The announcement is gone. Nothing left to dismiss. (I've disabled uBlock Origin for this check.)

There is lively discussion going on in the PR still. Note we don't recommend content-blocking it as it may contain important information.

Because of the length of this, it's likely we'll use different identifiers for the updated version.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Now the change has landed, and will be in the next release.

Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Blocks: 1531117
You need to log in before you can comment on or make changes to this bug.